Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
285 Views

Installation to Linux VM

Hi,

We have the project working in Window with Intel Fortran Compiler for years and like to see if

we can compile the project in Linux VM before we buy the Linux license, I tried the trial version

and when I install, I got this error:

Missing critical prerequisite
-- Xorg X11 libXss runtime library is not found. 'Graphical user interface'
component of VTune Amplifier cannot be installed.

Wonder if I could install the Fortran Compiler without the graphical user interface? Thanks!

Liying

 

0 Kudos
16 Replies
Highlighted
Valued Contributor I
285 Views

You downloaded the complete package including the VTune profiling tools. I think when you just download the Parallel Studio component and not the full package then you don't need X11 and graphics support.

 

0 Kudos
Highlighted
Beginner
285 Views

I have tried the customized package, as my VM is Intel 64, I choose

Select the target architecture(s) where the applications you develop will run.
--------------------------------------------------------------------------------

   1. [ ]    IA-32
   2.     Intel(R) 64

and I have choose:

  1. Accept and continue [ default ]
   2. [None] Intel Trace Analyzer and Collector 2019 Update 3
   3. [None] Intel Cluster Checker 2019 Update 2
   4. [None] Intel VTune Amplifier 2019 Update 3
   5. [None] Intel Inspector 2019 Update 3
   6. [None] Intel Advisor 2019 Update 3
   7. [All] Intel C++ Compiler 19.0 Update 3
   8. [All] Intel Fortran Compiler 19.0 Update 3
   9. [All] Intel Math Kernel Library 2019 Update 3 for C/C++
   10.[All] Intel Math Kernel Library 2019 Update 3 for Fortran
   11.[All] Intel Integrated Performance Primitives 2019 Update 3
   12.[All] Intel Threading Building Blocks 2019 Update 4
   13.[None] Intel Data Analytics Acceleration Library 2019 Update 3
   14.[None] Intel MPI Library 2019 Update 3
   15.[None] GNU* GDB 8.0
   16.[None] Intel(R) Distribution for Python*

but after I accept configuration and begin install, I got:

Missing optional prerequisites
-- missing system commands
-- 32-bit libraries not found

Please advice what I need to do to get this resolved? Thanks!

Liying

 

0 Kudos
Highlighted
Black Belt Retired Employee
285 Views

First, I'll comment that you don't need Threading Building Blocks nor Integrated Performance Primitives as those are for C/C++ only.

You need the 32-bit gcc libraries: Development for a 32-bit on a 64-bit host may require optional library components (ia32-libs, lib32gcc1, lib32stdc++6, libc6-dev-i386, gcc-multilib, g++-multilib) to be installed from your Linux distribution.

Also:

Linux Developer tools component installed, including gcc, g++ and related tools. (this is the list of component versions tested by Intel; other versions may or may not work and are not recommended - please refer to Technical Support if you have questions

gcc 4.4 to gcc 7

binutils 2.20 to binutils 2.29

Library libunwind.so is required in order to use the -traceback option.  Some Linux distributions may require that it be obtained and installed separately.

0 Kudos
Highlighted
Beginner
285 Views

I checked, both gcc and binutils are already installed when installed devtool,

Package binutils-2.27-34.base.el7.x86_64 already installed and latest version

gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/4.8.5/lto-wrapper
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-linker-hash-style=gnu --enable-languages=c,c++,objc,obj-c++,java,fortran,ada,go,lto --enable-plugin --enable-initfini-array --disable-libgcj --with-isl=/builddir/build/BUILD/gcc-4.8.5-20150702/obj-x86_64-redhat-linux/isl-install --with-cloog=/builddir/build/BUILD/gcc-4.8.5-20150702/obj-x86_64-redhat-linux/cloog-install --enable-gnu-indirect-function --with-tune=generic --with-arch_32=x86-64 --build=x86_64-redhat-linux
Thread model: posix
gcc version 4.8.5 20150623 (Red Hat 4.8.5-36) (GCC)

I don't use -traceback option, so Library libunwind.so is not necessary...

Any other suggestions?

0 Kudos
Highlighted
Black Belt Retired Employee
285 Views

Try customizing the compiler component to install only the x64 part. It is trying to install the 32-bit compiler as well.

0 Kudos
Highlighted
Beginner
285 Views

I did unselect IA-32, but it still tries to install 32-bit compiler, there is nowhere else than below

that I can unselect IA-32.

 

Select the target architecture(s) where the applications you develop will run.
--------------------------------------------------------------------------------

   1. [ ]    IA-32
   2.     Intel(R) 64

0 Kudos
Highlighted
Beginner
285 Views

Strange, I go ahead ignoring the missing component and it seems to be installed successfully.

Thanks!

Liying

0 Kudos
Highlighted
Beginner
285 Views

Hi Steve,

I  need to link Fortran code with c code, I have compiled and linked everything, but I got error when I execute it,

the error message is: undefined symbol: __svml_log2, I google and found out there was an old inquiry that

you replied to include libsvml.a, I wonder if it is due to some components that I didn't install, so the library is

missing? I only installed Fortran related component, but gcc is installed when I installed development tookl.

Thanks!

Liying

 

0 Kudos
Highlighted
Black Belt Retired Employee
285 Views

libsvml.a is part of Intel Fortran and C++. If you use ifort to link, which is usually recommended, this should get referenced automatically.  Otherwise you will need to name it on the command used to link.

0 Kudos
Highlighted
Beginner
285 Views

Hi Steve,

My project requires to use gcc to link, wonder if you can offer some advice how to name it on the command?TThanks!

Liying

0 Kudos
Highlighted
Black Belt Retired Employee
285 Views

Like any other library, -lsvml . The path to libraries should already be established once you "source" the ifortvars.sh (or .csh) script.

You can use ifort to link even with gcc objects. It ends up calling ld anyway.

0 Kudos
Highlighted
Beginner
285 Views

Hi Steve,

I have got over that issue, now error message is:

ERROR: /home/lxh37/Desktop/proc_lca/lca: undefined symbol: __kmpc_ok_to_fork

I searched and it seems that I need to use -lpthread and libiomp5 library? I did both,

but couldn't get rid of the error, any other advice? Thanks!

Liying

0 Kudos
Highlighted
Beginner
285 Views

I figured it out, I also need to add -liomp5 option...

0 Kudos
Highlighted
Beginner
285 Views

Now I have message

undefined symbol: for_f90_index

search around, don't know which library I should include for this one....

Liying

0 Kudos
Highlighted
Black Belt Retired Employee
285 Views

Probably -lifcore

0 Kudos
Highlighted
285 Views

Hi

I downloaded parallel studio_xe_2019 cluster edition; initial release then the update 3. I need fortran compiler to use planck likelihood plc-2.1_py3 I sourced the tool by  putting in my .bashrc source psxevars.sh intel64 as indicated in the installation instruction of the product. the which ifort command gives the answer /opt/intel/compilers_and_libraries_2019.3.199/linux/bin/intel64/ifort.

But when i configure plc-2.1_py3 I got the message ifort not found. Could someone help me find the issue?

With my best regards

0 Kudos