Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
4 Views

Intel Fortran

I just installed Intel fortran parallel_studio_xe_2018 on ubuntu 16.04 64-bit machine.
 but when i tried to compile a fortran program, i get the message: ifort: command not found.

I understand that its related to environment setting but i am unable to work

. in my .bashrc file i have tried using following  but none has worked

source /opt/intel/compilers_and_libraries_2018/linux/bin/compilervars.sh intel64

source /opt/intel/compilers_and_libraries_2018.1.163/linux/bin/compilervars.sh intel64

source /opt/intel/bin/compilervars.sh intel64

when i type source .bashrc on command terminal i get  Illegal variable name

ifort -v gives   ifort: Command not found.

  • i also need to link dynamic libraries and want to give it in bash file. pl helpcommand not found

thanks

anand

0 Kudos
10 Replies
Highlighted
Valued Contributor I
4 Views

I think that does not

I think that does not necessarily export the path. You might have to source also ifortvars.sh. Or just by end export the path. Or execute

source /opt/intel/compilers_and_libraries_2018.1.163/linux/bin/intel64/ifort

0 Kudos
Highlighted
4 Views

In your .bashrc file you

In your .bashrc file you should put this:

source /opt/intel/compilers_and_libraries_2018/linux/bin/compilervars.sh intel64

 

Once you do that, you do NOT need to source .bashrc.   Everytime you create a new command window it will happen 'automatically'. 

If you are still having problems, please do a screenshot of your command window, showing what commands you issued, so there is no confusion.

                           --Lorri

0 Kudos
Highlighted
Beginner
4 Views

as told, i used following

hi lorri

as told, i used following command in .bashrc file source /opt/intel/compilers_and_libraries_2018/linux/bin/compilervars.sh intel64 the screen shot of commands used is attached. when at terminal i write ifort -v, i get ifort: Command not found. to run a sample programme, ifort x.f i get ifort command not found

2  there is no change, error still persists ? Am i missing certain prerequisites... though i didnt get ant message while installing ifort

2 should i reboot hhe system before testing ?

0 Kudos
Highlighted
Valued Contributor I
4 Views

Obviously there is an error

Obviously there is an error in your .bashrc, otherwise it wouldn't show ILLEGAL VARIABLE NAME.

0 Kudos
Highlighted
Beginner
4 Views

@ Juergen pl help

@ Juergen pl help. i didnt make any  change in bash file. its the same at the time of installation. or what can i do

0 Kudos
Highlighted
4 Views

what happens if you do NOT

what happens if you do NOT put the command into .bashrc, and simply try to invoke it from the command line, as:

source /opt/intel/compilers_and_libraries_2018/linux/bin/compilervars.sh intel64

Do you see a failure?  Can you invoke ifort?

 

0 Kudos
Highlighted
Black Belt
4 Views

Anand, without knowing what

Anand, without knowing what is on your computer and lacking an accurate description of the situation, there is not much that we can tell you. You said in #1 that you had changed your .bashrc file. Then in #6 you say that you did not make any changes. Unless you made a backup of the file and restored it, how can we be sure that things are as they were originally? It is a bad idea to start changing such system configuration files without a backup and without knowing exactly why changes are to be made. Alternatively, you need access to a local Unix guru who can  help you.

0 Kudos
Highlighted
Beginner
4 Views

hi lorri,

hi lorri,

i did what you suggested

anand-HP:~> source /opt/intel/compilers_and_libraries_2018/linux/bin/compilervars.sh intel64  and i got


PROD_DIR=/opt/intel/compilers_and_libraries_2018/linux: Command not found.
INTEL_TARGET_ARCH=: Command not found.
INTEL_TARGET_PLATFORM=linux: Command not found.
COMPILERVARS_ARGV=1: Command not found.
if: Expression Syntax.
then: Command not found.

even if i comment above command in .bashrc file and type soure .bashrc at terminal and enter i get illegal variable name

i am using ububtu 16.04 64 bits

pl guide

anand

0 Kudos
Highlighted
Valued Contributor I
4 Views

There seem to be two options:

There seem to be two options: either the file you are sourcing got corrupted (particularly the line starting

#!/bin/sh

got erased, or you are running a very strange shell. What does

echo $0

show?

0 Kudos
Highlighted
Beginner
4 Views

Thanks Lorri and Juergen R ..

Thanks Lorri and Juergen R ... i have sorted out issue. ifort is working fine.

i want to LD path to export use bin and mkl files and want environment be set so that shared libraries are automatically taken during compilation . how to do it.

2  i am getting segmentatation fault in my output. i did ulimit -s. but it didnt help me. i am sure its a problem in linking of shared files. strange thing is i could successfully create binaries using intel cluster 16, 17 and composer edn 15. but now i am unable to do it.

ur expertise might help me in resolving issue.

 

ab

0 Kudos