Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner

Intel® Parallel Studio XE Composer Edition18.0 for Fortran macOS* in Xcode9.4.1

Hi all

Intel® Parallel Studio XE Composer Edition for Fortran macOS* 18.0 (Student) & Xcode9.4.1 had installed. 

Question is I can not find Intel® Fortran Compiler in Using Option when Build Rules.

Refer to intel® Fortran Compiler 18.0 Developer Guide and Reference, reinstalled the compiler (step a) and It does not work to change directory to the installation directory for the intel® Compiler IDE integration (step b) : cd  /Library/Application\ Support/Developer/, no such file or directory shows in terminal window.

Someone help,

Best regards 

 

 

0 Kudos
7 Replies
Highlighted
Valued Contributor I

I'm a bit lost what the exact

I'm a bit lost what the exact question is: you cannot find how to install the ifort Fortran Compiler, or you cannot afterwards find the ifort executable, or you cannot find an IDE? 

 

0 Kudos
Highlighted
Beginner

Quote:Juergen R. wrote:

Juergen R. wrote:

I'm a bit lost what the exact question is: you cannot find how to install the ifort Fortran Compiler, or you cannot afterwards find the ifort executable, or you cannot find an IDE? 

 

It's really hard to say, cause the question I just can't define. I wanna compile Fortran in Xcode. But now, When i create a new Xcode project, choose Command line tool in Application, then Build Rules for Process: Fortran source files, and I just can't find Intel® Fortran Compiler in using option

0 Kudos
Highlighted
Valued Contributor I

Ok, I cannot help you with

Ok, I cannot help you with that. I do software development under MACOSX, but in the console, I don't use XCode.

0 Kudos
Highlighted
Beginner

引文:Juergen R. 写道:

Juergen R. wrote:

Ok, I cannot help you with that. I do software development under MACOSX, but in the console, I don't use XCode.

Thanks anyway

0 Kudos
Highlighted
Moderator

 

According to the release notes, macOS 10.13 and Xcode 9.3 are supported with Intel Fortran Compiler 18.0.3..  

Here's a link to the release notes, https://software.intel.com/en-us/articles/intel-fortran-compiler-180-for-macos-release-notes-for-intel-parallel-studio-xe-2018. Earlier versions of the compiler work with earlier versions of macOS and Xcode.  Details are in the release notes.

0 Kudos
Highlighted
Beginner

Quote:Barbara P (Intel) wrote

Barbara P (Intel) wrote:

According to the release notes, macOS 10.13 and Xcode 9.3 are supported with Intel Fortran Compiler 18.0.3..  

Here's a link to the release notes, https://software.intel.com/en-us/articles/intel-fortran-compiler-180-for-macos-release-notes-for-int.... Earlier versions of the compiler work with earlier versions of macOS and Xcode.  Details are in the release notes.

It doesn't work well in Xcode 9.4. Now I have no idea about what happened and what I should do...

0 Kudos
Highlighted
Beginner

Hey  guys

Hey  guys

The problem above has already solved by version:2019 perfectly

Thanks ALL

 

 

0 Kudos