Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
26730 Discussions

Intel fortran installed but can not be used

ali__qais
Beginner
1,426 Views

Hello Intel,

I dowlnoaded parallel_studio_xe_2019_update3_cluster_edition and then custom installed Intel fortan and Vtune amplifier as shown below;

1. Accept and continue [ default ]
   2. [None] Intel Trace Analyzer and Collector 2019 Update 3
   3. [None] Intel Cluster Checker 2019 Update 2
   4. [All] Intel VTune Amplifier 2019 Update 3
   5. [None] Intel Inspector 2019 Update 3
   6. [None] Intel Advisor 2019 Update 3
   7. [None] Intel C++ Compiler 19.0 Update 3
   8. [All] Intel Fortran Compiler 19.0 Update 3
   9. [None] Intel Math Kernel Library 2019 Update 3 for C/C++
   10.[None] Intel Math Kernel Library 2019 Update 3 for Fortran
   11.[None] Intel Integrated Performance Primitives 2019 Update 3
   12.[None] Intel Threading Building Blocks 2019 Update 4
   13.[None] Intel Data Analytics Acceleration Library 2019 Update 3
   14.[None] Intel MPI Library 2019 Update 3
   15.[None] GNU* GDB 8.0
   16.[None] Intel(R) Distribution for Python*
Then it showed some missing pre-requistes as shown below;

Prerequisites > Missing Prerequisite(s)
--------------------------------------------------------------------------------
There are one or more unresolved issues based on your system configuration and
component selection.

You can resolve all the issues without exiting the installer and re-check, or
you can exit, resolve the issues, and then run the installation again.

--------------------------------------------------------------------------------
Missing optional prerequisites
-- 32-bit libraries not found
--------------------------------------------------------------------------------
   1. Skip prerequisites [ default ]
   2. Show the detailed info about issue(s)
   3. Re-check the prerequisites

 

I pursued with installation and installed successfully; 

Installation
--------------------------------------------------------------------------------
Each component will be installed individually. If you cancel the installation,
some components might remain on your system. This installation may take several 
minutes, depending on your system and the options you selected.
--------------------------------------------------------------------------------
Installing Platform Profiler component... done
--------------------------------------------------------------------------------

Installing Command line interface component... done
--------------------------------------------------------------------------------
Installing Sampling Driver kit component... done
--------------------------------------------------------------------------------
Installing Graphical user interface component... done
--------------------------------------------------------------------------------
Installing Intel Fortran Compiler for Intel(R) 64 component... done
--------------------------------------------------------------------------------
Finalizing product configuration...
--------------------------------------------------------------------------------
Installing Application Performance Snapshot... done
--------------------------------------------------------------------------------
Preparing driver configuration scripts... done
--------------------------------------------------------------------------------

But now when I type in the terminal ifort then it says command ifort not found. I am using ubuntu 18.04. Your suggestions are highly acknowledged.

 


 

0 Kudos
1 Solution
jimdempseyatthecove
Black Belt
1,400 Views

Prior to using the compiler you must setup (select) the environment.

Depending on what you want, this will be something like:

source /opt/intel/2019/bin/ifortvars.sh intel64

There is a similar souce command for including mpi

Please read the documentation about setting up the build environment.

https://software.intel.com/en-us/articles/setting-up-the-build-environment-for-using-intel-c-or-fort...

Sorry about the above link being old, Look in your current documentation (Or google)"

"linux Setting Up the Build Environment for Using Intel 2019 fortran"

or

"linux getting started Intel 2019 fortran"

Jim Dempsey

 

View solution in original post

20 Replies
jimdempseyatthecove
Black Belt
1,401 Views

Prior to using the compiler you must setup (select) the environment.

Depending on what you want, this will be something like:

source /opt/intel/2019/bin/ifortvars.sh intel64

There is a similar souce command for including mpi

Please read the documentation about setting up the build environment.

https://software.intel.com/en-us/articles/setting-up-the-build-environment-for-using-intel-c-or-fort...

Sorry about the above link being old, Look in your current documentation (Or google)"

"linux Setting Up the Build Environment for Using Intel 2019 fortran"

or

"linux getting started Intel 2019 fortran"

Jim Dempsey

 

View solution in original post

ali__qais
Beginner
1,399 Views

Dear Jim Dempsey,

Thank you very much for your detailed and helpful guidance.! I followed the link mentioned by you and this one is updated in April 2019, so I resolved my issue and now I can make my code with ifort. Just as a side comment, since I did not install rest of the features of Intel parallel studio apart from Intel Fortran and Vtune amplifier so in future is there a probability that my calculation may get influence due to other uninstalled compilers and libraries? Further, you mentioned about mpi, do I also need to source mpi to use ifort efficiently?

With kind regards,

Qais

jimdempseyatthecove
Black Belt
1,399 Views

When your application does not use MPI then you do not need to source the mpi shell script.

Is there a reason why you did not install all of the packages from Intel?

You should be ok with what you installed for building and running Fortran applications as long as you do not include some of the extended libraries. For example MKL, MPI, etc...

Jim Dempsey

ali__qais
Beginner
1,399 Views

Dear Dempsey,

I guess for the time being I do not need MPI, but I will use it in future subject to requirement.

Reasons for not installing all packages are partially related to space availability but mainly my program only requires Intel fortran for now so I preferred custom installation. However, during installation, I once tried to install all packages to the directory where I have around 400 GB  free space but still I was getting error of space limitations.

Best,

Qais

Ron_Green
Moderator
1,399 Views

So besides the target directory, the compiler has to extract the RPMs in temp space, default is /tmp.  What does 'df -k' show for that, if it's in a separate partition or something perhaps it is constrained.  You can export TMPDIR to a location with more space perhaps.

ali__qais
Beginner
1,399 Views

Dear Mr. Ronald,

df -k sows following;

qais@qais-Y11B:/tmp$ df -k
Filesystem     1K-blocks     Used Available Use% Mounted on
udev             1944516        0   1944516   0% /dev
tmpfs             395048     2124    392924   1% /run
/dev/sda2       30126968 27745372    828188  98% /
tmpfs            1975236    17304   1957932   1% /dev/shm
tmpfs               5120        4      5116   1% /run/lock
tmpfs            1975236        0   1975236   0% /sys/fs/cgroup
/dev/loop0         36224    36224         0 100% /snap/gtk-common-themes/1198
/dev/loop1          2304     2304         0 100% /snap/gnome-calculator/260
/dev/loop2         35456    35456         0 100% /snap/gtk-common-themes/818
/dev/loop3         14976    14976         0 100% /snap/gnome-logs/45
/dev/loop5         55040    55040         0 100% /snap/core18/782
/dev/loop4          1024     1024         0 100% /snap/gnome-logs/57
/dev/loop7         55040    55040         0 100% /snap/core18/941
/dev/loop9        144128   144128         0 100% /snap/gnome-3-26-1604/82
/dev/loop8         91392    91392         0 100% /snap/core/6673
/dev/loop10         4224     4224         0 100% /snap/gnome-calculator/406
/dev/loop11        35712    35712         0 100% /snap/gtk-common-themes/1122
/dev/loop12         1024     1024         0 100% /snap/gnome-logs/61
/dev/loop13       154752   154752         0 100% /snap/gnome-3-28-1804/51
/dev/sda1         523248     6228    517020   2% /boot/efi
/dev/loop15        15104    15104         0 100% /snap/gnome-characters/280
/dev/loop14        55040    55040         0 100% /snap/core18/970
/dev/loop16       144128   144128         0 100% /snap/gnome-3-26-1604/86
/dev/loop17        90624    90624         0 100% /snap/core/6964
/dev/loop18        91648    91648         0 100% /snap/core/6818
/dev/loop21         3840     3840         0 100% /snap/gnome-system-monitor/83
/dev/loop22         4224     4224         0 100% /snap/gnome-calculator/352
tmpfs             395044       20    395024   1% /run/user/120
tmpfs             395044       64    394980   1% /run/user/1000
/dev/loop23         3840     3840         0 100% /snap/gnome-system-monitor/87
/dev/loop24        15104    15104         0 100% /snap/gnome-characters/284
/dev/loop25       154880   154880         0 100% /snap/gnome-3-28-1804/55
/dev/sdb1      488384000 41575292 446808708   9% /media/qais/EEFEC13CFEC0FE39

I have a lot of space in "EEFEC13CFEC0FE39" directory I guess.

ali__qais
Beginner
1,399 Views

Dear all,

I am using ifort to run a fortran based code which runs Monte Carlo simulations. I can run code successfully for some of  the calculations but for others I am facing dimension error, what could be the possible reasons, can it be related to array allocation or size of my pc memory? How may I resolve this issue? Your suggestions are highly acknowledged. 

Best regards,

Qais

Juergen_R_R
Valued Contributor I
1,399 Views

First of all, this is a different issue, so please open up another thread. Questions you should answer are: 1. which Monte Carlo simulation / which code, 2. compilation error or runtime error, 3. what is the exact error message, 4. please show some code.

 

jimdempseyatthecove
Black Belt
1,399 Views

>>can it be related to array allocation or size of my pc memory?

Possibly (we haven't seen your code)

If you are defining a parameter to specify the size of your array .AND. the array is statically allocated:

REAL :: ARRAY(YourBigParameterNumberHere)

Then depending on where ARRAY is located (module, COMMON or local to the procedure), it will either be a static array or a stack allocated array. In the case of a static array, you may have a linker limitation of 2GB, if on the stack then you may have a stack limitation.

To work around this, it is suggested that  you make the array ALLOCATABLE

REAL, ALLOCATABLE :: ARRAY(:)
...
! Somewhere early in your program
ALLOCATE( ARRAY(YourBigParameterNumberHere))

Jim Dempseyt

ali__qais
Beginner
1,399 Views

Dear all,

 

Many thanks for your continuous support. I have been using ifort version 19.0.3.199 20190206.  Now, I would like to use 2020 version of ifort, but I am unable to find a (easy and quick) way of doing it. Can anyone please share a helpful link in this regard or a method to follow? Thanks in advance!

Best,

Ali 

Devorah_H_Intel
Moderator
1,399 Views

There is no 2020 version of ifort. The latest version of the Intel Fortran Compiler is 19.1 that is available as part of Parallel Studio XE 2020

Please see this article for additional information https://software.intel.com/en-us/articles/intel-compiler-and-composer-update-version-numbers-to-comp...

ali__qais
Beginner
1,399 Views

Thanks Devorah, I updated ifort to 19.1 version and it helped in my work. 

ali__qais
Beginner
1,399 Views

Dear all,

I have recently tried to install intel parallel_studio_xe_2020.0.088 on my computer system and started to source to set-up the environment as given below;

~/intel_ifort/parallel_studio_xe_2020.0.088/compilers_and_libraries_2020/linux/bin> source compilervars.sh
but I am facing following error.

PROD_DIR=/home/ali/intel_ifort/compilers_and_libraries_2020.0.166/linux: Command not found.
INTEL_TARGET_ARCH=: Command not found.
INTEL_TARGET_PLATFORM=linux: Command not found.
INTEL_HOST_PLATFORM=Linux: Command not found.
COMPILERVARS_ARGV=0: Command not found.
COMPILERVARS_ARGV: Undefined variable.

Your kind suggestions to resolve this issue are greatfully acknowledged.  

Cheers,

Qais Ali

WHeat__Had
Beginner
1,399 Views

Hello,

I have a question : how I can integrate Intel Parallel Studio 2020 to Mirosoft Visual Studio ?

I installed Microsoft Visual Studio 2019 in first and after that, I installed Intel Patallel Studio 2019, but when I launch Microsoft Visual Studio to write a Fortran code, I don't find intel(R) Visual Fortran.

Best,

jimdempseyatthecove
Black Belt
1,399 Views

The normal procedure is:

Start a shell (this usually places you in your home directory)
cd to your project folder
from your project folder source the intel compiler variables. something like:

    source /opt/intel_ifort/parallel_studio_xe_2020.0.088/compilers_and_libraries_2020/linux/bin/compilervars.sh intel64

IOW specify the path to the installation folder (which may differ from that I wrote above) together with the shell script file and followed by the argument intel64 .OR. ia32

See: https://software.intel.com/en-us/articles/setting-up-the-build-environment-for-using-intel-c-or-fort...

Jim Dempsey

ali__qais
Beginner
1,399 Views

Dear Jim,

Thanks for your kind response. I used to use ""source compilervars.sh -arch intel64 -platform linux" before, which worked well for me. This time I installed intel on another computer system of mine and did the same, just like you also suggested (please see below)

~/intel_ifort/parallel_studio_xe_2020.0.088/compilers_and_libraries_2020/linux/bin> source compilervars.sh -arch intel64 -platform linux  

 

However, the problem remains same.


PROD_DIR=/home/ali/intel_ifort/compilers_and_libraries_2020.0.166/linux: Command not found.
INTEL_TARGET_ARCH=: Command not found.
INTEL_TARGET_PLATFORM=linux: Command not found.
INTEL_HOST_PLATFORM=Linux: Command not found.
COMPILERVARS_ARGV=4: Command not found.
COMPILERVARS_ARGV: Undefined variable.

 I wonder if it has to deal with some other stuff apart from source issue.

Best wishes,

Qais
 

JohnNichols
Valued Contributor II
1,399 Views

https://software.intel.com/en-us/get-started-with-fortran-compiler-linux

You appear to be not using the correct commands. it took 20 seconds of searching to find the correct commands - see above. 

In this world you need to follow the fm. 

Jim appears to have it correct 

Enter source compilervars.sh ia32|intel64 or source compilervars.csh ia32|intel64

this does not mean source ......

Enter source is English for enter everything after the word source not including source - it is an idiom:

Command prompt>compilervars.sh ia32|intel64

pick either 32 or 64 versions. 

Good hunting.  

 

WHeat__Had
Beginner
1,399 Views

Hello,

How I can integrate Intel Parallel Studio to Microsoft Visual Studio ? (I need to compile a Fortran code)

Thanks

Steve_Lionel
Black Belt Retired Employee
1,399 Views

The article is terrible and I have asked Intel to fix it. When it says "ia32|intel64" it doesn't mean that literally - it is trying to say pick one or the other. Also the article doesn't make it clear that you have to include the path to the script in the "source" command.

jimdempseyatthecove
Black Belt
500 Views

In Linux there is the concept of current directory. When you launch a Terminal Window, you typically start in your login's home directory. Usually indicated by ~. The Terminal Window prompt on my system looks like:

[jim@KNL ~]$

Note, your prompt may look like:

[YourUserNameHere@YourSystemNameHere ~]$

From here you usually use cd to change your directory to that of your development:

[jim@KNL ~]$cd workspace/foobar

[jim@KNL foobar]$

At this point you "source" the compilervars

[jim@KNL foobar]$source /opt/intel_ifort/parallel_studio_xe_2020.0.088/compilers_and_libraries_2020/linux/bin/compilervars.sh intel64

You only type in what follows the $

In the above, I elected to specify the 64-bit build environment

*** This environment is set (active) until you exit the shell (terminal)

Note 2: If you (incorrectly) run the compilervars.sh directly (i.e. as opposed to via source), the shell script will pop off the IVF environment variable settings. Using the command "source" preserves the settings that are set in the shell script compilervars.sh.

You will get familiar with this behavior as you use the system.

Jim Dempsey

Reply