Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
26755 Discussions

Intellisense is not working for FORTRAN variables declared in mixed or lower case letter.

Sudip_Chakraborty
180 Views

I am trying to debug a FORTRAN code written in mixed case letters. The project is setup as VS 2013 project with Intel(R) Visual Fortran 2015. I just cannot make the IDE display the variable value while debugging. However, if I retype the variable in uppercase in the watch window, it displays fine. Is there a setting I have to turn on to make this work? 

0 Kudos
2 Replies
Sudip_Chakraborty
180 Views

I figured this out following the thread  https://software.intel.com/en-us/forums/intel-visual-fortran-compiler-for-windows/topic/392429. I discovered the thread later, after posting my request.

Thank you.

 

Kevin_D_Intel
Employee
180 Views

I'm glad you found a resolution.

It appears this behavior has changed in VS2015. I do not have the older PSXE 2015 (15.0)  integrations installed but with our PSXE 2017 (17.0) integrations I am not seeing this behavior under VS2015. I confirmed the variables are not accessible under VS2013 (w/17.0 integrations) with Native Edit and continue enabled, but with those same integrations under VS2015, with Native Edit and continue enabled,  I am able still view scalars/arrays on the Watch/Quickwatch/Local views.

Again, glad you found a resolution. Thank you for post back your resolution/finding.

Reply