Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

Invalid or Unavailable License Issue

Le__Dat
Beginner
115 Views

Hello,

The most similar forum post I've found is linked below:

Licensing?

I have an existing desktop machine with Intel Parallel Studio XE Composer Edition 2018 Update 2 installed and a license file in C:\Program Files (x86)\Common Files\Intel\Licenses. My end use of the fortran compiler is CRTech's SINDA solver/Thermal Desktop within AutoCAD 2017. On this existing machine, I've been able to use the compiler with no issues.

On a new, separate desktop machine, I am trying to install Intel Parallel Studio, copy the license file, and use the compiler in the same fashion. However, when I attempt to run the SINDA solver, I run into issues that I can attribute to the fortran compiler. I tried going into the fortran compiler command prompt environment and running "ifort" to see the output, and I get a message saying that my license is not available, as shown in the attached image.

My support expired Apr 14, 2019, but my license was originally obtained in 2017 and my support renewed only once in 2018. According to the Intel FAQ, I should be able to use any version of Intel Parallel Studio XE Composer Edition released prior to Apr 14, 2019, correct? Once Windows SDK 10 is installed, I'm under the impression that all other pre-requisite software is included in the installer (Microsoft Visual Studio 2015 Shell), but I can't imagine that this would manifest as a license error as I've just described.

Any thoughts or ideas on what the true issue might be? Have I just downloaded the incorrect version of Intel Parallel Studio?

Thanks,

-Dat

 

0 Kudos
1 Reply
Steve_Lionel
Black Belt Retired Employee
115 Views

First, please edit your attached image (or remove it) as it includes a license number.

Second, you should use the Intel Online Service Center to report all licensing issues. These can't reasonably be dealt with in the forum. The details of the license are important.

Third - the following will give you more information:

set intel_lmd_debug=1
ifort -c

 

Reply