Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1 View

Linking IMSL 7 with IVF 2016

Hi,

I have just upgraded to the latest version of IVF (parallel studio xe 20016) and IMSL (7) (I have the composer edition with IMSL).  I am running Visual Studio Shell 2010.  I have legacy code dating back to CVF which uses IMSL routines, which includes the following lines in the main program (which worked with the previous version of IVF:

INCLUDE 'link_fnl_static.h'

!DEC$ OBJCOMMENT LIB:'libiomp5md.lib'

When I try to compile the code in the new fortran version I get a the following errors:

Error 1  error #5102: Cannot open include file 'link_fnl_static.h' C:\Working\Design\ASM2d Rev 2c\ASM2d\ASM2d.f90 776 

Error 2  error #7002: Error in opening the compiled module file.  Check INCLUDE paths.   [NUMERICAL_LIBRARIES] C:\Working\Design\ASM2d Rev 2c\ASM2d\ASM2d.f90 773 

I read the topic 'Installing and using the IMSL libraries', which describes how to select options in Visual Studio (and the command line, which unfortunately I am unfamiliar with).  I'm guessing VS shell is not correctly configured ?  But how do I change VS shell to the right settlings and what are the right settlings ? Or is there something else wrong ?

Regards

 

 

 

 

 

0 Kudos
4 Replies
Highlighted
Black Belt
1 View

Did you go through the steps

Did you go through the steps in "Using the IMSL Libraries from the Integrated Development Environment (Windows* OS)" at https://software.intel.com/en-us/node/524759 ?

0 Kudos
Highlighted
1 View

When you install a new

When you install a new version of Parallel Studio XE, you may have to redo any modifications of include and library paths.

Retired 12/31/2016
0 Kudos
Highlighted
Beginner
1 View

Thanks for the comments, but

Thanks for the comments, but the information at  https://software.intel.com/en-us/node/524759 seems to relate to Visual Studio (which I don't have) and not Visual Studio Shell (which I do have).  When I go into Tools > Options I get Intel Composer XE.  When I go into that I get 'Codecov' and 'Profmerge' options and not any option that allows me to select Visual Fortran or compliers etc.  So I'm still not clear about what I need to do.

Regards 

0 Kudos
Highlighted
1 View

Visual Studio Shell is the

Visual Studio Shell is the same as Visual Studio as far as this is concerned. If you are seeing "Intel Composer XE" then you don't have the 2016 product properly installed. It should look like this:

Capture_0.PNG

 

If you're not seeing this, try the repair step at https://software.intel.com/en-us/articles/troubleshooting-fortran-integration-issues-with-visual-studio/

Retired 12/31/2016
0 Kudos