Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
36 Views

Pre-processor include files and Visual Studio issue

Jump to solution

Hello,

I have two VMS running Visual Studio 2012 Ultimate but they both have different versions of the Fortran compiler installed:

VM #1: Intel(R) Visual Fortran Compiler XE 14.0.6.241 [IA-32]
VM #2: Intel(R) Visual Fortran Compiler 17.0.4.210 [IA-32]

I have a simple Fortran test project on both VMs and I am testing an issue with preprocessor include files that was brought up to me. On VM #1 when you have a syntax error in the included header file and you try to double-click on the error in the Visual Studio error list window it does not take you to the exact line where the error is. However on VM #2 if you double-click on the error it does take you to the included file and the exact line where the syntax error is.

In what compiler version was this issue fixed? The only way I am able to get around it is to remove the preprocessor "#" in the include, build the project, and then you are able to double-click on the error. I have attached a screenshot with what I mean.

If you need more clarification let me know. Thank you!

JP

0 Kudos

Accepted Solutions
Highlighted
Black Belt Retired Employee
36 Views

Intel releases complete new installs, not patches. There would have been one version or update with the fix, not something that is "applied" to older versions. My guess is that this sort of bug was fixed in a major new version, not one of the updates. Try version 16.  Perhaps one of the Intel folk can query the internal bug report database to see if they can locate my escalation of this issue. I am pretty sure the fix was in the compiler, not in fpp.

View solution in original post

0 Kudos
7 Replies
Highlighted
Black Belt
36 Views

Precompiled headers would be for c++.  As it's possible to install either of your ifort versions with or without Microsoft (and possibly also Intel) c++, I don't see what answers you could expect.

0 Kudos
Highlighted
Beginner
36 Views

Tim I apologize I meant preprocessor includes not pre-compiled. I edited the post

0 Kudos
Highlighted
Black Belt Retired Employee
36 Views

I recall that there was a bug related to how preprocessor include files were identified by line number in the compiled source. It was fixed, but I don't remember in which version.

0 Kudos
Highlighted
Beginner
36 Views
Thank you Steve! Do you know if there is a patch available for this version? (Intel(R) Visual Fortran Compiler XE 14.0.6.241 [IA-32]). The reason why I am asking is because I have a customer that is using this version throughout many of their developer machines and their code contains many nested include files with the preprocessor directive set (# include). They have a hard time debugging issues since they cannot go into the file.
0 Kudos
Highlighted
36 Views

Try adding -P after -fpp (as additional command line option).

This removes the preprocessor annotations for #line-number file-name.

In older versions of IVF I had a similar problem with the line numbers in the debugger not lining up. This corrected the problem for me. It is easy enough for you to try.

Jim Dempsey

0 Kudos
Highlighted
Black Belt Retired Employee
37 Views

Intel releases complete new installs, not patches. There would have been one version or update with the fix, not something that is "applied" to older versions. My guess is that this sort of bug was fixed in a major new version, not one of the updates. Try version 16.  Perhaps one of the Intel folk can query the internal bug report database to see if they can locate my escalation of this issue. I am pretty sure the fix was in the compiler, not in fpp.

View solution in original post

0 Kudos
Highlighted
Beginner
36 Views

Sounds good. I will contact support and see if they can query the bug report database and tell me the version where it got fixed. Thanks again for your help!

JP

0 Kudos