Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
13 Views

Resource compiler not activating in Visual Studio

I am trying to transfer to a new Computer.  However the resource compiler is not being activated on the new computer.  When I do  Rebuild on the old computer it comes up with 1>Compiling resources.... On the new one this does not come up.  What are the various switches that should be checked to get the resource compiler to run?  I have set the default application for .rc files to visual studio as this is what the old computer has and also to c:\program files (x86)\Windows Kits\8.1\bin\x64\rc.exe but neither worked.  One of the other posts mentioned a reset button under tools\options\intel compilers\Fortran but I cannot find it.  I am using Visual studio Community 2015 on Windows 7, Parallel_studio_xe_2016.3.059

Thanks for your help

0 Kudos
7 Replies
Highlighted
Valued Contributor II
13 Views

The resource compiler is

The resource compiler is installed as part of the C language so you need to ensure that that is selected during the visual studio install. I am not sure that is added by default. I would do an re-install of VS. The setting you are playing with should all be set up automatically by the install.

 

 

0 Kudos
Highlighted
13 Views

Thank you.  I managed it at

Thank you.  I managed it at the second attempt.

You need to remove any association of file extensions .rc  .rc2 and .rct  before running Visual Studio install, (repair might do it.)

see eg http://www.howtogeek.com/171932/how-do-you-remove-a-default-file-association-in-windows-7/

 

0 Kudos
Highlighted
Beginner
13 Views

I have same problem with

I have same problem with resource compiler. Resinstallation did not solve the problem. What is also funny Visual Studio C++ DOES WORK but fortran project do not. That makes me thing that something is wrong with Intel Fortran Composer (Im using 2013 version).

Any ideas?

Thanks!

0 Kudos
Highlighted
Employee
13 Views

As in this case that you

As in this case that you posted to here, are you also using Visual Studio Community 2015?

If so, did you verify during the installation of that what is cited in Installing Visual Studio 2015 for Use with Intel Compilers?

The earlier thread here contains advice on other things to check/try:

  1. Since you comment C++ is working, I’m sure you already confirmed, as is suggested in post #4 of the earlier thread I cited above, that Visual C++ is installed. Can't hurt to review the Help > About to verify Visual C++ is present.
  2. As suggested in post #6 of the earlier thread, can you try clicking Reset under Tools > Options > Intel Compilers and Tools > Visual Fortran > Compilers
  3. Also from post #6 of the earlier thread, search your system to see where you find rc.exe, and try adding the full path in the Executables list on the Compilers page mentioned in post #6 of that thread (and item 3 above).
  4. If reaching this point, then as discussed in post #8, you may need to install the Windows SDK for Windows 8.1.

Hope that helps

0 Kudos
Highlighted
13 Views

I eventually found the

I eventually found the problem.

When I installed Winteracter on the new computer I ticked the box saying associate .rc files with the Winteracter resource editor.  I had to  manually removed the association with Winteracter resource editor, before running the Intel compiler setup program again to get the correct association.  The Intel compiler setup would not reset the association if it had already been associated.

0 Kudos
Highlighted
13 Views

The extensions .rc .rc2 .rct

The extensions .rc .rc2 .rct are all associated with Microsoft Visual Studio

0 Kudos
Highlighted
Black Belt
13 Views

What I have usually done in

What I have usually done in these situations is delete the registry entry HKEY_CLASSES_ROOT\.rc and do a "repair" on Visual Studio.

Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos