Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
26732 Discussions

Using old compiler versions with Intel Parallel Studio XE 2018

Sam_Harrison
Beginner
149 Views

I have Visual Studio 2017 installed alongside Intel Parallel Studio XE 2018, and have tried to use these instructions to select an older version of the compiler to use. However, I cannot find older versions of the compiler (17 and below) under Tools > Options. I also can't find any reference to older versions in the directory C:\Program Files (x86)\IntelSWTools (is this the correct place to be looking?). Any help would be very grateful!

Sam

0 Kudos
5 Replies
Steve_Lionel
Black Belt Retired Employee
149 Views

You need to have previously installed the older version(s), and the version you want must support the VS version you are using.

Sam_Harrison
Beginner
149 Views

Ah, I think I was mis-interpreting the line "With the 2018 version, you have access to compiler version 14.0, 15.0, 16.0, 17.0 and 18.0" as meaning that Intel Parallel Studio XE 2018 comes with 14-18, rather than it works with previously-installed versions 14-18.

I presume older versions aren't available to install separately with a 2018 license?

andrew_4619
Honored Contributor I
149 Views

Yup you can download and use older versions that are at at the intel download centre but you need to be mindful of what versions of visual studio a fortran version is capable of integrating with. 

mecej4
Black Belt
149 Views

Every compiler installer that I have obtained from Intel contains exactly one major-minor number combination, e.g., 2017-Update4. You can look up the corresponding release notes to see which hardware-OS-VS combination is suitable for that particular installer.

Sam_Harrison
Beginner
149 Views

Thanks all, useful information. Got Intel Fortran 16 installed, now I need an old version of VS! ;)

Reply