Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
26740 Discussions

VS 2015 hanging when writing a left parenthesis

Emanuel_C_
Beginner
105 Views

Hi all,

I am facing an issue that when typing code my visual studio is hanging whenever I open a new parenthesis. This issue was previously reported here: https://software.intel.com/en-us/forums/intel-visual-fortran-compiler-for-windows/topic/366189 however I am new to FORTRAN and also Visual Studio so I did not understand the solution given. Can someone help me solving this?

I am using:
-Microsoft Visual Studio Community 2015 -Version 14.0.25431.01 Update 3
-
Inter Parallel Studio XE 2017 Update 4 Composer Edition for Fortran Windows 

Best regards and many thanks

0 Kudos
3 Replies
Steve_Lionel
Black Belt Retired Employee
105 Views

I don't find the option I mentioned in that old post that the developers said they would add. Try this,

In Visual Studio, go to Tools > Options > Text Editor > Fortran > Advanced. Set all the choices to False.  Click OK and restart Visual Studio.

I have seen this problem with very long source files. It doesn't "hang" in that it will eventually resume, but it is incredibly annoying.

jimdempseyatthecove
Black Belt
105 Views

If you are not willing to turn off Advanced features, try entering

) LeftArrow (

IOW enter the close paren first, then back arrow to insert open paren second, and then continue inserting text betwixt.

"fairest tapestrie that I ever saw, I wald that the haill feyldis that is betwix this place and yon war strewit with the same stuiffe"

Jim Dempsey

Emanuel_C_
Beginner
105 Views

Steve Lionel (Ret.) wrote:

I don't find the option I mentioned in that old post that the developers said they would add. Try this,

In Visual Studio, go to Tools > Options > Text Editor > Fortran > Advanced. Set all the choices to False.  Click OK and restart Visual Studio.

I have seen this problem with very long source files. It doesn't "hang" in that it will eventually resume, but it is incredibly annoying.

Many thanks for the answers. 
Surprisingly I was facing the problem with very small codes (<200 lines).

From yesterday, I updated my parallel studio to Update 5 and also disabled the hardware graphics acceleration if available under Tools, Options , Environment.

I think it was the update that solved the problem (don't know if it makes sense as I updated Parallel Studio and not VS) since I can activate the graphics acceleration and still works!  At the moment under Tools > Options > Text Editor > Fortran > Advanced I only have the option Disable Database False. 

 

 

Reply