Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
28543 Discussions

VS2022 17.0.5 disabling Fortran 2022.1 projects?

MWind2
New Contributor III
545 Views

Not sure if VS2022 is culprit, maybe old computer with lots of installs. Project for fortran referenced version 11.0 which has not been on computer for a long time. Compiled before 17.0.5, though. Investigating.

Did repair of 2022.1 HPC and VS17.0.5 complained about project tools again, clicked "project scope to this" and the project was available. Rebuilt using 2021.5.0 fortran, no change to project file that I noticed.

<VisualStudioProject ProjectType="typeDynamicLibrary" ProjectCreator="Intel Fortran" Keyword="Dll" Version="11.0".

Maybe only my problem not anyone else.

 

 

0 Kudos
2 Replies
JohnNichols
Valued Contributor III
512 Views

I do not think you are alone, there is a bug in the new VS 2022 and the oneapi. 

I reported this on the mkl forum, and @mecej4  showed me where to find the 32 bit mkl install. 

I had the problem with the identical "apparent" project files. 

I solved it by removing all of the vs stuff and all of the intel installs.  I cleaned out all the old SDK builds from MS. 

I use ccleaner to clean the registry, Dr Fortran says no,  your choice. 

I then installed VS 2019 and VS 2022 and then only the latest one api and I installed the 32 bit MKL, look on the MKL forum for the link. 

You need vs 2019 to run the vars.bat or it throws a brickbat through the window of life. 

I threw away the sln and project files for the problem one and recreated them, they look the same, but it worked. 

Good luck.  

 

 

0 Kudos
MWind2
New Contributor III
502 Views

I suspect VS has more "race" conditions than before. The winform designer was the first I remember from VS2010-ish days. 17.0.?-3 would not load f90 files until a decent interval and a click on the file again. Once projects were "scope to this" they load OK at start up afterward.  

0 Kudos
Reply