Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
278 Views

Visual Studio cannot debug because a debug target has not been specified

Jump to solution

When trying to run a specific solution from inside VS2008 we get this error message. The same error occurs both when starting in Debug mode and in Release mode. Before upgrading from VS2005 to VS 2008 and from IVF 10.0.25 to IVF 10.1.021 and to IVF 11.0.075 it worked fine. There is a DLL in this specific solution. Other solutionsworks fine.

Any help appreciated.

0 Kudos

Accepted Solutions
Highlighted
New Contributor II
278 Views
Solutions cannot be run, only projects. When you hit F5 VS attempts to start the active project.

If you have a project that is an exectable one then that project needs to be set to be the active project (the one shown in bold). If you only have a dll, then you can only debug that if you specify what executable to attach to or you can attach to an already running executable.

View solution in original post

0 Kudos
4 Replies
Highlighted
New Contributor II
279 Views
Solutions cannot be run, only projects. When you hit F5 VS attempts to start the active project.

If you have a project that is an exectable one then that project needs to be set to be the active project (the one shown in bold). If you only have a dll, then you can only debug that if you specify what executable to attach to or you can attach to an already running executable.

View solution in original post

0 Kudos
Highlighted
Beginner
278 Views
There are several projects within this solution and you were right about the startup project. Somehow I must have managed to change this. After changing the startup project back to the main project it works fine again. Thank you so much for your fast help!
0 Kudos
Highlighted
Beginner
278 Views

I get the same message when I create a new project in VS2008. The only project in the solution is a Intel 11.1 Main project that contains a Main program file in fortran. What Am I missing?

0 Kudos
Highlighted
278 Views

Did you build the application successfully?  In the project properties, Fortran > Debugging, what is shown for Command?

0 Kudos