Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
36 Views

cannot add a new file to a blank project ?

It used to be that I could just type in a source file, the first one of a new project, and include it.

I cant do that anymore. why did they disable that in VS 2013 ?

I could in VS 2010.

 

It no longer gives me that choice.

 

Dont they test this stuff ?

0 Kudos
18 Replies
Highlighted
Black Belt
36 Views

Visual Studio is a Microsoft product. Intel only adds Fortran support. Only some combinations of Visual Studio and Intel Fortran are supported.

You can use another IDE if you do not like Visual Studio, or simply use Nmake, Cmake or MSBuild inside a command window to build Fortran projects.

0 Kudos
Highlighted
New Contributor I
36 Views

Oh, so we have to use an untested version of Visual Studio to use your new Fortran ?

Can I discuss this with your manager ?

0 Kudos
Highlighted
Valued Contributor III
36 Views

It used to be that I could just type in a source file

What does that mean, could you spend a few minutes explaining exactly what it is you used to be able to do and now can't? Opening a new source file and typing into it is something you can do in VS2013. Most of the contributors on this site are not Intel employees BTW. 

 

 

0 Kudos
Highlighted
Employee
36 Views

We test our Fortran integrations with Visual Studio.

The steps outlined in our User’s Guide under Creating a new Project, https://software.intel.com/en-us/node/677905, including adding an existing file are available and function with our PSXE 2017 release Visual Studio 2013 specifically, and other supported VS versions. It is unclear what difficulty you experienced or whether the steps in our UG discussing adding a file represent what you indicate no longer functions on your setup. If they don't and you can offer some additional detail then we can try those steps on our side.

0 Kudos
Highlighted
New Contributor I
36 Views

Well, I start a NEW project, and then since it is empty, I want to type in one source file, just 2 lines, for example.

PROGRAM TEST

END PROGRAM

I would like to compile that, but I first have to add the new source file to the empty project.

It wont let me do that - what it will do is allow a source file from some other project.

 

after it does that, I can type in OTHER source files to add to the project.

 

Its a  minor annoyance, but we did not see that with VS 2010,

you could start from scratch with that.

i have a 64 bit DELL, with fortran 17.0 and VS 2013.

 

so the hangup is when I try to add a new source file to an EMPTY project by typing it in.

0 Kudos
Highlighted
Black Belt
36 Views

I think that I now guess what the problem you have hinted at is. You expect a new, blank, unnamed file to be opened by default when you create a new project. Perhaps things worked like that in an older version of Visual Studio, and perhaps there is some setting in other versions VS that will let you reinstate that kind of behavior.

All that you have to do is press Ctrl+N and select a file type, or use File-New- and select a file type. The menus show a list of acceptable file types for the project type that you have created: for example, .f90, .for, .inc, etc., for a Fortran project. Just click on one of them and name the new file.

0 Kudos
Highlighted
36 Views

Launch MS VS 2013
Click on New Project under Start on Start Page
(or click: File | New | Project)

On New Project dialog click/open:

Installed | Templates | Intel(R) Visual Fortran | Console Application | Empty Project
(specify name and location)
check or uncheck box to create a sub-folder under location for project
Click OK


You now have a Solution with one Project and no source files

In Solution Explorer pane

Right-Click on Source Files
Under Installed | Intel(R) Visual Fortran Project Items
choose file format (e.g. Fortran Free-form File (.F90)
specify name (and location if you want different from default project location)


*** note, if you do not see: New Project | Installed | Templates | Intel(R) Visual Fortran

Then Intel Parallel Studio/or Composer is not integrated into MS VS

Jim Dempsey

0 Kudos
Highlighted
New Contributor I
36 Views

Well, that is not the problem.

It will not let me install the NEW SOURCE file into the project.

 

I did NOT expect a new blank file, I am trying to add one.

 

It wont let me do that .

 

It used to be that I could add a dummy file( main program), now I cannot.

 

Why dont you allow a remote login/assist , that would make it real simple to show someone what is going on,

instead of this endless blather going back and forth ?

0 Kudos
Highlighted
New Contributor I
36 Views

Did STEVE LIONEL RETIRE ?

I am really gonna miss him - he got to the point.

0 Kudos
Highlighted
Employee
36 Views

Only posting because you're not alone in asking. He will retire soon, Doctor Fortran's next chapter and hopefully remain active in the forums. He will be missed.

0 Kudos
Highlighted
Valued Contributor III
36 Views

billsincl wrote:

.. Why dont you allow a remote login/assist , that would make it real simple to show someone what is going on, instead of this endless blather going back and forth ? ..

Bill,

If you can find someone who can help you, who is willing to offer all the time it will take to help sort out your myriad problems with the OS and the IDE and the compiler and the user, and whose advice you will follow up on (this is ultimately the most important aspect, I think), you can set up remote assistance sessions yourself using the Windows 10 facility of "Quick Assist": https://support.microsoft.com/en-us/help/27919/windows-10-get-help-with-pc-problems.

 

 

 

 

0 Kudos
Highlighted
New Contributor I
36 Views

wELL, i AM CERTAINLY WILLING TO PAY FOR SOMEONE'S TIME, IF

THEY CAN GIVE ME AN INTELLIGENT ANSWER.

Certainly beats going back in forth, rather than someone criticizing my Fortran code, when that is not even the issue.

 

I have to use to USE the debugger effectively in order to iron out any problems with the code,

which is something I cant do with the latest stuff they have put out.

 

The problem, is not WINDOWS 10, it is the Microsoft IDE - but no one in this forum takes responsibility for that.

well, I can see why. But why wont Microsoft fix it ?

0 Kudos
Highlighted
Employee
36 Views

Everyone,

With all due respect,

@billsincl - I know it is frustrating when the Development tools do not work. We all recognize you are experiencing a number of issues and we are trying to reach out to help. I will be in touch to offer some remote access/help to see if we can work through the issues you are facing. Please remain respectful and focus exchanges on what will help resolve issues or answer questions.

On behalf of Intel, we thank everyone for their active participation, willingness to share knowledge, and deep desire to help others. Our Fortran forums are among the most active, friendly, and respectful of our forums and we certainly want them to continue with those traditions. There is a great community of Fortran users in the forums with a deep knowledge, passion, and desire to share and help, and I know none of us wants to distract from that. Let us all please do what we can to remain respectful in our exchanges.

Thank you.

Sincerely,
Kevin

(Sorry, for replicating – just trying reach everyone in the various threads)

0 Kudos
Highlighted
36 Views

Billsincl,

Considering that my post #8 did not yield a solution for you, I can only presume what you are doing.

Microsoft Visual Studio has a structure of:

Solution
   Project
      Files
   Project
       Files
   Project
       Files

Upon starting Microsoft Visual Studio, if you specify "Empty Solution", then your Solution has no Projects. A Project in Microsoft Visual Studio includes properties such as Project Type, such as Intel Visual Fortran, C++, C#, Python, etc.. Therefor, if your Solution has no Project(s), in particular a Fortran Project, then there is no way for Visual Studio to know the scope of the files (and file templates) to use, or where you wish to place the files.

Follow the sequence shown on #8 above and see what happens (report at how far you get).

I hope this help.

Jim Dempsey

0 Kudos
Highlighted
New Contributor I
36 Views

WELL, IT USED TO BE UNDER VS2010 that

when I type in a new file, and call it fortran free form, it would give it a type of F90.

 

and then I had an option to move it into the project. In this case it is the current default project.

 

I no longer have that option when the file is the FIRST one.

 

So I am wondering if there is  a special trick to allow me to move the new file into the blank project.

 

Of course if the files are F90, it would know how to compile them, right ? The fortran is installed there (17.0),

but I have to get it into the project first. well I will try #8, see what happens.

0 Kudos
Highlighted
36 Views

>>So I am wondering if there is  a special trick to allow me to move the new file into the blank project.

So then why not create a Fortran Project, call it Blank, create your tentative files there (you can even compile and debug them there which you cannot do using what you want to do), then copy/move them to the Intended Project when satisified?

Jim Dempsey

0 Kudos
Highlighted
Employee
36 Views

I am unable replicate the problem that I believe you experienced based on the added detail in post #16. The “File > Move <filename> Into” functionality you describe works the same under VS2013 as VS2010.

My steps were:
1. Create a new empty Fortran Console project
2. Ctrl-N, select Fortran Free-form File (it gets auto-named Source1.f90), then insert some code (did not save the file yet)
3. Use File > Move Source1.f90 Into and select the newly created empty Fortran project

At the completion of step 3, the file contents are saved and the file is added to the Project.

We can walk through this on your system. For now I just wanted to share my steps.

0 Kudos
Highlighted
36 Views

I'll comment that the recommended approach is to use Project > Add New Item...

0 Kudos