Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
28606 Discussions

command not recognized when setting up Intel MPI Library

zhzhu1218
Novice
691 Views

Hello,

 

I used to work with MPI codes using Intel Parallel Studio + VS 2019 + Fortran, and just updated to openAPI + VS 2022 + Fortran. When following the guide here (https://www.intel.com/content/www/us/en/docs/mpi-library/get-started-guide-windows/2021-6/overview.html) to set up the updated Intel MPI Library, I get through the first two steps (hydra_service -install; hydra_service -start). But when I key in mpiexec -register, the command prompt pops out '-register' is not recognized as an internal or external command, operable program, or batch file.

zhzhu1218_0-1686762671470.png

 

Am I making a silly mistake here?

 

Thanks!

0 Kudos
3 Replies
Ron_Green
Moderator
677 Views

I think that documentation may be out of date.  My research shows that you should no longer need to do that -register step to enter your username/password credentials. 

 

Try running MPI jobs.  It should work without the -register step/

0 Kudos
zhzhu1218
Novice
675 Views

Thanks Ron (truly appreciate your help so far with the multiple questions I've been facing when setting things up)! I tried running a simple hello world MPI job, but somehow it only runs with one thread (see first attached image for the result) despite me specifying the program to use 4 threads in the command arguments (as shown in the 2nd attached image). Any idea why this is happening?

zhzhu1218_1-1686770564695.png

 

zhzhu1218_0-1686770502633.png

 

0 Kudos
zhzhu1218
Novice
674 Views

ps. Here's the relevant part of the program I'm running

 

zhzhu1218_0-1686770712143.png

 

0 Kudos
Reply