Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
27551 Discussions

error #5102: Cannot open include file 'link_fnl_shared.h'

Yvan
Novice
1,416 Views

Hi, I am trying to compile a Fortran code that invokes an IMSL library routine. I get the following error:

error #5102: Cannot open include file 'link_fnl_shared.h'

I installed IMSL from RogueWave using a license file they provided me with. I followed all the instructions indicated here. I use Visual Studio 2019.

Can someone help me please?

0 Kudos
1 Solution
Yvan
Novice
1,387 Views

The compiler I am using is Intel® Fortran Compiler Classic 2021.1.1 [Intel(R) 64].

The IMSL library I installed is Fortran Numerical Library 2020, Platform Windows 10 / Parallel Studio 2019 (x64).

 

In Visual Studio, Menu Tools -> Options -> Intel Compilers and Libraries -> IFORT Intel Fortran Classic I added to Libraries:

$C:\Program Files (x86)\RogueWave\imsl\fnl-2020.0.0\win100in170x64\lib

and I added to Include:

$C:\Program Files (x86)\RogueWave\imsl\fnl-2020.0.0\win100in170x64\include\dll

 

Is there something else I should be doing?

 

View solution in original post

4 Replies
mecej4
Black Belt
1,410 Views

Which version of the Intel compiler do you use, and which version of IMSL? Depending on the answers, you may need to run the IMSL configuration script fnlsetup.bat in order to inform the compiler where to look for the IMSL include files, libraries and DLLs.

Yvan
Novice
1,388 Views

The compiler I am using is Intel® Fortran Compiler Classic 2021.1.1 [Intel(R) 64].

The IMSL library I installed is Fortran Numerical Library 2020, Platform Windows 10 / Parallel Studio 2019 (x64).

 

In Visual Studio, Menu Tools -> Options -> Intel Compilers and Libraries -> IFORT Intel Fortran Classic I added to Libraries:

$C:\Program Files (x86)\RogueWave\imsl\fnl-2020.0.0\win100in170x64\lib

and I added to Include:

$C:\Program Files (x86)\RogueWave\imsl\fnl-2020.0.0\win100in170x64\include\dll

 

Is there something else I should be doing?

 

Yvan
Novice
1,349 Views

Actually, I solved the issue by removing the '%'sign in front of both directories

In Visual Studio, Menu Tools -> Options -> Intel Compilers and Libraries -> IFORT Intel Fortran Classic

add to Libraries:

C:\Program Files (x86)\RogueWave\imsl\fnl-2020.0.0\win100in170x64\lib

add to Include:

C:\Program Files (x86)\RogueWave\imsl\fnl-2020.0.0\win100in170x64\include\dll

 

mecej4
Black Belt
1,343 Views

Why do you prefix the path strings with the '$' character?

Reply