Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
28543 Discussions

error #7002: Error in opening the compiled module file. Check INCLUDE paths. [MPI]

farega
Beginner
7,396 Views

I was Compiling  a simple mpi_hello Fortrdan code ( use MPI) with Intel(R) Visual Fortran Compiler 17.0.4.210 [Intel(R) 64].., I   Intel® oneAPI HPC Toolkit but I am getting the error message  error #7002: Error in opening the compiled module file. Check INCLUDE paths. [MPI]

 

Thanks

farega

0 Kudos
1 Solution
15 Replies
andrew_4619
Honored Contributor III
7,381 Views

I would guess (there is no code shown) the the sample has a USE MPI statement to pull some MPI module data and the project has not been configured to know where that compiled module is located.  Is MPI installed by the way?

 

0 Kudos
farega
Beginner
7,352 Views

Thanks. Here is the code.

******************************

program MPI_hello
use mpi
implicit none
integer ierr
call MPI_Init(ierr)
WRITE(6,*)'Hello World'
call MPI_Finalize(ierr)
end program MPI_hello

********************

I  am using Intel(R) Visual Fortran Compiler 17.0.4.210 [Intel(R) 64] with Viusla Stuido 2015. I tried to install ONEAPI but is not compatible.

 

 

 

0 Kudos
Ron_Green
Moderator
7,375 Views

most MPI libraries use a wrapper.  So for Intel MPI for example

 

mpiifort hello.f90 -o hello_mpi.exe

 

What MPI, version, and wrapper are you using?

0 Kudos
farega
Beginner
7,342 Views

Thanks. Here is the code.

******************************

program MPI_hello
use mpi
implicit none
integer ierr
call MPI_Init(ierr)
WRITE(6,*)'Hello World'
call MPI_Finalize(ierr)
end program MPI_hello

********************

I  am using Intel(R) Visual Fortran Compiler 17.0.4.210 [Intel(R) 64] with Viusla Stuido 2015 community. I tried to install ONEAPI but is not compatible.

 

0 Kudos
Ron_Green
Moderator
7,336 Views

The easiest path for you is this:

 

1) FIRST Get and install the latest Microsoft Visual Studio Community Edition from HERE assuming you qualify for their licensing.  If you qualify there is no charge.  Make sure to install the C++ Component

 

2) AND THEN Install the oneAPI HPC Toolkit.  All components in that Toolkit including Intel MPI

 

 

0 Kudos
farega
Beginner
7,317 Views

The only compatible Visual studio with my  Intel(R) Visual Fortran Compiler 18.0.3.210 is 17 or 15.  oneAPI HPC Toolkit compianied on VSC 2015 but was fine with VSC 2017. I tried and get the same error message.

 

Thanks

 

0 Kudos
Steve_Lionel
Honored Contributor III
7,313 Views

Intel Fortran does not provide support for building MPI applications. You need to install a compatible MPI (such as Intel MPI) and then add to the "Include directories" list the path to where the MPI includes and modules can be found. Depending on the MPI you choose, you may have to compile the module sources.

I don't recommend using the newer Intel MPI in the HPC Toolkit with the older compiler.

0 Kudos
farega
Beginner
7,306 Views

i installed Intel® oneAPI HPC Toolkit on VisualStudio 2017

0 Kudos
Steve_Lionel
Honored Contributor III
7,297 Views

You still need to add the path to the Fortran MPI modules so that the compiler knows how to find them.

0 Kudos
farega
Beginner
7,272 Views

Thanks,

the MPI module is installed at C:\Program Files (x86)\Intel\oneAPI

 

I then  set,

1)  Project-Properties-Fortran-General-Additional include Directories $(I_MPI_ONEAPI_ROOT)\include;

2) Project-Properties-Linker-General-Additional include directories $(I_MPI_ONEAPI_ROOT)\lib\debug;. 

 

Any other way to set the path?

 

0 Kudos
Steve_Lionel
Honored Contributor III
7,264 Views

That should do it. Are you sure you are building an x64 target configuration? Intel MPI does not support 32-bit applications. Does mpi.mod exist in that folder?

Please zip the buildlog.htm from a failed build and attach it to a reply here.

0 Kudos
farega
Beginner
7,256 Views

Thanks.

I am using X64 configration. However, I could not locate  mpi.mod.

Here is the log.

 

------ Build started: Project: Project1, Configuration: Debug x64 ------
1>Compiling with Intel(R) Visual Fortran Compiler 18.0.3.210 [Intel(R) 64]...
1>Source1.f90
1>C:\FCZWQM\ysa\Source1.f90(2): error #7002: Error in opening the compiled module file. Check INCLUDE paths. [MPI]
1>compilation aborted for C:\FCZWQM\ysa\Source1.f90 (code 1)
1>
1>Build log written to "file://C:\FCZWQM\ysa\x64\Debug\BuildLog.htm"
1>Project1 - 2 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

0 Kudos
Steve_Lionel
Honored Contributor III
7,244 Views

If you could not find it, that tells me you don't have Intel MPI installed. Fortran provides only pieces of Intel MPI necessary to support coarrays. In the Windows Settings > Apps list, do a "Modify" on Intel oneAPI HPC Toolkit and check the box for Intel MPI. Complete the install. It should then work.

0 Kudos
farega
Beginner
7,233 Views

Thank you so much. I did but I get the following

The Intel(R) Librarian (xilink.exe) could not be found.

0 Kudos
Reply