Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
124 Views

ifort: command not found

Hello everyone,

i am a student from Germany and new to Linux and Intel Fortran etc. I need to work with feap for class. Therefore I got some files.

Using the "make" command for the "Makefile" i get an error message:

make
============= compiling feap ===============
(cd /home/matti/Dokumente/feap81/SRC;/usr/bin/make -f Makefile feap)
make[1]: Entering directory '/home/matti/Dokumente/feap81/SRC'
ifort -c -O2 -Iinclude -Iinclude/integer8 -Iinclude/eigenes -Iinclude/eigenes/integer8 user/ielmt28.f -o ../OBJ/user/ielmt28.o
make[1]: ifort: Command not found
Makefile:36: recipe for target '../OBJ/user/ielmt28.o' failed
make[1]: *** [../OBJ/user/ielmt28.o] Error 127
make[1]: Leaving directory '/home/matti/Dokumente/feap81/SRC'
Makefile:15: recipe for target 'fe' failed
make: *** [fe] Error 2

I installed the Intel Fortran Compiler and all other compilers after I installed Linux Mint 18 yesterday.

If you need some further information, please let me know.

Thanks in advance,

Matti

 

0 Kudos
4 Replies
Highlighted
Beginner
124 Views

I read a lot about this problem, seems to be a problem a lot of people have.

"source /opt/intel/Compiler/11.1/056/bin/ifortvars.sh intel64" helped me. (I changed this to my preferences)

But now there is a now problem. I get the following message:

ifort  -o ../feap -L/usr/X11R6/lib64 -lX11 -lm ../64b/*.o -L../lib -lmkl_solver -lmkl_lapack -lmkl_em64t -lguide -lpthread ../lib/feaplib.a
ifort: warning #10315: specifying -lm before files may supersede the Intel(R) math library and affect performance
ld: cannot find -lX11
Makefile:30: die Regel für Ziel „feap“ scheiterte
make[1]: *** [feap] Fehler 1
make[1]: Verzeichnis „/home/matti/Dokumente/Bachelorarbeit/feap81/SRC“ wird verlassen
Makefile:15: die Regel für Ziel „fe“ scheiterte
make: *** [fe] Fehler 2

Can you help me with this one?

Best regards,

Matti

0 Kudos
Highlighted
Black Belt Retired Employee
124 Views

You need to "source" the compiler configuration script:

source /opt/intel/bin/ifortvars.sh

(or .csh depending on your shell.)

0 Kudos
Highlighted
Black Belt
124 Views

Check if you have the library file /usr/X11R6/lib64/libX11.a (or a corresponding shared version) on the system.

You probably do not need the -lm options, unless you are linking with some libraries that depend on the standard Linux library libm.a (or libm.so).

 

0 Kudos
Highlighted
Beginner
124 Views

Hi Steve, 

I get the same IFORT command not found when I try and create a .obj file with the following:

IFORT /fpp /nologo /Od /Oy- /assume:buffered_io /traceback /libs:dll /threads /c /Qip ^
      /extend_source:132 /noaltparam /fpscomp:logicals /warn:declarations ^
      /warn:unused /warn:truncated_source /Qauto /Op /iface:cvf /define:DLLI ^
      /include:"C:\Program Files (x86)\PTI\PSSE32\PSSLIB" ^
      /object:"%fname%_32.obj" ^
      "%fname%.f"

Any advice would be appreciated. The code originally written for IVF11 and I am now using IVF17 with visual studio 2010.

Thanks in advance

Johan H

0 Kudos