Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner

makefile can't find ifort, ifort -v returns a license error

I installed Intel(R) Parallel Studio XE Cluster Edition on my system running Ubuntu 14.04.4. I updated my .bashrc files to include /home/chris/intel/bin.

which ifort returns: /home/chris/intel/bin/ifort

However, when I try to use make to build an openmpi version of some Monte Carlo software, I get several error messages to the effect of

 

ifort: error #10052: could not checkout FLEXlm license
make[2]: *** [import/mars-routines-2.o] Error 1
--- import/mars-routines.o ---

Error: A license for Comp-FL is not available (-76,61026,2).

License file(s) used were (in this order):
    1.  Trusted Storage
**  2.  /home/chris/intel/compilers_and_libraries_2016.2.181/linux/bin/intel64/../../Licenses
**  3.  /home/chris/Licenses
**  4.  /opt/intel/licenses
**  5.  /Users/Shared/Library/Application Support/Intel/Licenses
**  6.  /home/chris/intel/compilers_and_libraries_2016.2.181/linux/bin/intel64/*.lic

Please refer http://software.intel.com/sites/support/ for more information..

 

 

ifort -v returns a similar message. Where should I start to fix this license issue? Thanks.

 

0 Kudos
1 Reply
Highlighted

You need to:"source" the

You need to:"source" the ifortvars.sh script, adding a parameter of intel64 or ia32 as appropriate.

As for the license, please log in to the Intel Registration Center and if it tells you that you need to "upgrade" your license, do that. Then save the license file on your system - ideally in /opt/intel/licenses

Retired 12/31/2016
0 Kudos