Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

qopt-report not working in ifort 18

Manfredo_d_
Beginner
135 Views

I am compiling my code like so

ifort -c -check -g -debug extended -debug-parameters -traceback -u -fp-stack-check -warn -guide -qopt-report=5 phenology_driv.f90
ifort: remark #10397: optimization reports are generated in *.optrpt files in the output location

However after compilation ends the file phenology_driv.optrpt only shows

Intel(R) Advisor can now assist with vectorization and show optimization
  report messages with your source code.
See "https://software.intel.com/en-us/intel-advisor-xe" for details.

Intel(R) Fortran Intel(R) 64 Compiler for applications running on Intel(R) 64, Version 18.0.0.104 Build 20170811

Compiler options: -c -check -g -debug extended -debug-parameters -traceback -u -fp-stack-check -warn -guide -qopt-report=5

In the project there are also a couple of C files and despite those being compiled with the same flags they actually contain report details.

Am I doing something wrong?

0 Kudos
3 Replies
Manfredo_d_
Beginner
135 Views

Yes I guess I was doing something wrong in that I had no optimization flags... 

Strange though that for the C files report was produced even with -O0.

However now I am faced with another issue: it takes an extremely long time to produce the outputs. I have one file (which admittedly is too long, around 30k lines) and since a couple of hours the compiler is stuck there.

TimP
Black Belt
135 Views

As you tacked this on to a subject with little relationship, without any details, you may not get at most generalities for answers.  Such a file may be too large to build with full optimizations; in particular, you might set -fno-inline-functions (assuming it has more than 1 procedure of significant size).

Manfredo_d_
Beginner
135 Views
Yes, Sorry. I posted an initial question but then realized my mistake. In fact since there are tens of files but just one that is that large. So I can easily set -O0 for that one and work first on the rest.
Reply