Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
27555 Discussions

"Non compatible version of Fortran libifcore DLL was loaded to process address space"

Mehika
Beginner
1,067 Views

Hi all,

 

I am trying to use Aspen Plus on my laptop, while installing the software, I get this error message. How do I fix this? i might've deleted this file before.. i am not sure. Thanks in advance

Mehika_0-1642204180934.png

 

0 Kudos
12 Replies
mecej4
Black Belt
1,030 Views

What I gather from the report is that Aspen Plus is looking for a specific version (or a newer one). Which version is that? That probably depends on the version of Aspen Plus that you are using, about which we have no information.

You can check which copies of libifcoremd.dll exist on your system and are accessible (through the %PATH% system variable) to Aspen Plus.

Steve_Lionel
Black Belt Retired Employee
1,015 Views

This is a message internal to the Intel library. libifport wants the same version of libifcore to be loaded, and they are not here. Some third-party applications carry along their own versions of the Intel DLLs rather than use the redistributable installer, and this can cause problems. 

I recommend installing the redistributables (see PSA: Update the Runtime Library when you update the compiler! - Intel Communities) and make sure that ASPEN PLUS is not using its own copies.

DavidWhite
Black Belt
1,005 Views

I'm an AspenPlus user.

What version of A+ are you using?  If you're not using the latest version of A+, then it may now know about the current version of Intel Fortran -- you should check the AspenTech site for updated versions of the aspcomp.bat file, so that Aspen links into the correct version of the compiler.  (We're still using v12 of the AspenOne suite for compatibility with other operations -- as a consequence the installed version of aspcomp did not have the correct name or path for the current Intel Fortran).

avinashs
New Contributor I
997 Views

Your problem appears to be during installation and not in using Fortran through A+. AspenPlus does not require the user to have Intel OneAPI or a Fortran compiler installed. However, AspenPlus does appear to unpack a number of libifcore*.dll (* = rtd,mmd,mdd etc.) and place them in C:\Windows\System32 and C:\Windows\SysWOW64 folders. When OneAPI is installed, the same files are installed in the OneAPI folders under Program Files (x86). The AspenPlus files have a date of 2017 or 2019, whereas the OneAPI files on my computer have a date of 2021. I have never had this error crop up in AspenPlus during installation although multiple versions of the files do exist. If you cannot get help from A+ customer support, perhaps best doing a clean install once again.

DavidWhite
Black Belt
957 Views

avinashs, do you definitely know that the Aspen install placed those files there -- my machine has no Intel runtime libraries under the Windows Systems folders.

 

Is it possible that these are part of an older install?

 

It could be useful to submit a support request to AspenTech, but need to be sure that this is the source of the problem.

 

Regards,

 

David

Hemang_Vadgama
Beginner
687 Views

Hello avinshs, While installing AspenPlus V12.1, I am getting these errors "The code execution could not procees because svml_dispmd.dll was not found. Reinstalling the program may fix this problem","The code execution could not procees because libifcoremd.dll was not found. Reinstalling the program may fix this problem", I tried clean installing aspen v12.1 multiple times, still facing same error. So please can you provide me these two dll files (svml_dispmd.dll,libifcoremd.dll) which are of 2017 or 2019(installed by aspen). I don't want OneAPI's libifcoremd.dll and svml_dispmd.dll files, I want the files provided by AspenPlus. It seems i have to place them manually in C:\Windows\System32 before starting installation!

Thankyou,

Hemang

avinashs
New Contributor I
637 Views

@Hemang_Vadgama You do not have to manually place any files such as libifcoremd.dll or svml_dispmd.dll - AspenPlus does the full install in one step for all the selected packages. If libifcoremd.dll is not available, it will be installed for you.

Since the error is during installation, the error could be most likely due to svml_dispmd.dll.

Some tips to troubleshoot -

1. Note that Aspen V12.1+ is 64-bit - so all files should be 64-bit compatible.

2. Make sure that the upgraded Sentinel License Manager (SLM V12.2) is correctly installed first and the licenses are recognized. Sometimes the errors are due to SLM. Aspen V12+ will not install with the older SLM in place.

3. libifcoremd.dll and svml_dispmd.dll is distributed by multiple programs so once installed, you cannot tell which program installed the version is System32.

Alina_S_Intel
Employee
972 Views

You can find libifcore.dll at C:\Program Files (x86)\Intel\oneAPI\compiler\2022.0.0\windows\compiler\lib\ia32_win and C:\Program Files (x86)\Intel\oneAPI\compiler\2022.0.0\windows\compiler\lib\intel64_win


This is a standard oneAPI installation. You can run oneAPI installer in Repair mode or remove and install again if you are not sure that the installation is correct.


You also need to add your oneAPI installation dir to your PATH before installing the product that depends on Intel Fortran. Please, consult with the installation guide of Aspen Plus to learn more about prerequisites.


Steve_Lionel
Black Belt Retired Employee
966 Views

While @Alina_S_Intel is correct that the DLLs can be found there, and those are used when running within Visual Studio or a command line build environment, they are not used when running outside those environments. Instead, the DLLs installed under Program Files(X86)\Common Files\Intel are used. These are supplied by the redistributables installer and added to PATH. It is not correct to add the oneAPI installation directories to the system PATH variable.

My guess is that Aspen Plus carries along its own copy of libifcore.dll but not libifport.dll, and the mismatch triggers the error. 

JohnNichols
Valued Contributor II
950 Views

28. “Perhaps one day we will have machines that can cope with approximate task descriptions, but in the meantime, we have to be very prissy about how we tell computers to do things.”

— Richard P. Feynman.

Seems to fit the bill. 

Steve_Lionel
Black Belt Retired Employee
677 Views

@Hemang_Vadgama , do NOT place those DLLs in the Windows System32 folder! Doing so will break other programs. I suggest installing the latest oneAPI runtime DLLs - this should be compatible with older code. If Aspen is copying those DLLs into a Windows folder, it is horribly broken.

Ron_Green
Moderator
672 Views

you can try the Dependencies tool.  point it to your A+ app and see what DLLs it needs, if they are found, and from where.

 

https://github.com/lucasg/Dependencies

 

 

Reply