Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Tobias_T_
Beginner
155 Views

Capture failed: Preview image conversion failed

Intel GPA is quite impressive, one of the best tools I've recently found :)

Unfortunately, I'm unable to capture a frame in my own DirectX 11 application (for testing reasons I deleted all code except the DirectX Initialization and Present). It always fails with the message "Preview image conversion failed" and the following log:

[00002d04] 16:52:46:641 |    INFO |     INTERCEPTOR | InterceptorDll.cpp:68    | GPA shim DLL attached.
[00002d04] 16:52:47:416 |    INFO |         CAPTURE | ShimMgt\CaptureManager.cpp:824   | D3D11 device context 00C9CBD4 created
[00002d04] 16:52:47:525 |    INFO |     INTERCEPTOR | ShimMgt\CaptureManager.cpp:3101  | Initializing Metrics Pipeline: ok
[00002d04] 16:52:50:620 |    INFO |         CAPTURE | ShimMgt\CaptureManager.cpp:3906  | Frame capture requested: C:\Users\Tobias\Documents\GPA\PostEffects_2016_09_07__16_52_50_615.gpa_frame
[00002d04] 16:52:50:620 |    INFO |         CAPTURE | ShimMgt\CaptureManager.cpp:859   | Start capture
[00002d04] 16:52:50:653 |    INFO |         CAPTURE | ShimMgt\CaptureManager.cpp:3924  | Capture message: Preview image conversion failed

[00002d04] 16:52:55:724 |    INFO |         CAPTURE | ShimMgt\CaptureManager.cpp:3906  | Frame capture requested: C:\Users\Tobias\Documents\GPA\PostEffects_2016_09_07__16_52_55_712.gpa_frame
[00002d04] 16:52:55:724 |    INFO |         CAPTURE | ShimMgt\CaptureManager.cpp:859   | Start capture
[00002d04] 16:52:55:767 |    INFO |         CAPTURE | ShimMgt\CaptureManager.cpp:3924  | Capture message: Preview image conversion failed

I tried it in other applicatiosn and there it works perfectly, such as World of Warcraft oder Starcraft 2. When I use DirectX 9 in my Application it works too. Under DirectX 11 the HUD is even showing and I can see the graphs running and use the debug option. Only the frame capture doesn't work.

Do you have any directions for me?

Thanks in advance!

0 Kudos
3 Replies
Seth_S_Intel
Employee
153 Views

Hi Tobias, 

Sorry for the late response!  

I have a couple workarounds you can try for frame capturing:

  • Try disabling "tracing" and trying a frame capture again.  Graphics monitor -> Profiles -> Tracing -> Disable Tracing
  • Try to inject with  "auto-detect launched application".  Graphics monitor -> Preference -> auto-detect launched applicatio

Also, If you could post your about dialog here so I can see what driver version and version of GPA you are using, that would be great.   

If these workarounds do not work for you, we might need to get a copy of your application so we can reproduce the issue here. 

Cheers!

Seth

Tobias_T_
Beginner
153 Views

Hi Seth,

I finally got it working today, while I was assembling the files to upload for you. The reason was a unused import of the DirectX 9 headers, which statically linked the DLLs into the application. I have no idea why this prevented the Graphics Monitor from capturing, but now with lazy loading everything works fine! It's curious that if I used DirectX 9 for rendering it worked, but with DirectX 11 and loaded DirectX 9 not.

If you want to track down this issue nevertheless, I've added all information you requested:

The workarounds didn't worked for me, nothing happened.

My About dialog:

Windows 10 build 10586, 64-bit DEP enabled
Num Processors: 4
Memory: 8111MB
System BIOS: American Megatrends Inc. P1.60 (07/03/2013)
Video BIOS: Version 80.04.C3.00.13  (06/06/13)
Driver 0:
     Device: NVIDIA GeForce GTX 770
     Provider: NVIDIA
     Date: 8-25-2016
     Version: 21.21.13.7270
     VendorId: 10de
     ProductId: 1184
     Stepping: a1
     No support for GPA Instrumentation
Install directory: C:\Program Files\IntelSWTools\GPA_16.2\
Version: 16.2.299487
Current user is in Administrators group: YES
Current Graphics Performance Analyzers 2016 R2 (16.2.299487)
Secure Boot/Trusted Boot is Disabled

And finally two reduced applications, one working one not:

https://drive.google.com/open?id=0B3HWSqf3Ke-mQVhjdi1FbEsxOXc

Thanks!

Tobias

 

Seth_S_Intel
Employee
153 Views

Great!  Glad to hear that everything is working now!

I have a couple ideas of why this could have failed.  I'l grab  your apps and I'll see if we can get a fix in for this.  

Anyway, i'm glad you are unblocked. :)

Cheers,

Seth

Reply