Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Illias_A_
Beginner
141 Views

GPA connection fail

Jump to solution
Hello. I've installed GPA and I'm trying to use it with up-to-date Samsung Galaxy S3 and Samsung Galaxy Tab E 9.6 devices. Google, Intel USB drivers are installed. Windows 10 Pro is used. On the first GPA installation System Analyzer successfully connected to both devices and displayed lists of installed applications. Next, I've installed necessary application on devices, but it was not possible to connect GPA anymore. It said "Cannot run application. This platform is not debuggable...". I've tried to reboot target devices, reboot windows, restart adb, reinstall GPA application on target devices, but nothing helped. What should I do?
0 Kudos
1 Solution
Seth_S_Intel
Employee
141 Views

Hi Illias, 

I looked into our support and we should be supporting both the S3 and the S4.  To reproduce your issue, we may need to get the application you are using. 

Feel free to private message me if that is possible. 

Is it working for any other applications?

Best,

Seth

View solution in original post

5 Replies
Illias_A_
Beginner
141 Views
I've managed to get it connecting on Samsung Galaxy S4, but when i select application to profile, GLESInfo window spawns, device reboots and GPA says "Device error: Connection to Android* device was lost..."
Seth_S_Intel
Employee
141 Views

Hi Illias, 

Sorry that you are running into some issues.   Since these devices are ARM based devices, we have somewhat limited support.

A couple questions:

  • What version of GPA are you using?
  • Are you devices rooted?
  • When selecting an application to analyze, is the application marked as "analyzable"?

The S3 is fairly old device, so we may not support it at all, but the S4 should be still in our support matrix.  I'll consult with our engineer that supports this and get back to you. 

Best,

Seth

Illias_A_
Beginner
141 Views
Thank you for such quick response. Version is 2015 R4 (15.4.276272) Yes, S4 (GT-I9500) is rooted. Well, application is listed in "User applications" block. Internet permissions and manifest debuggable flag are also set for app.
Seth_S_Intel
Employee
142 Views

Hi Illias, 

I looked into our support and we should be supporting both the S3 and the S4.  To reproduce your issue, we may need to get the application you are using. 

Feel free to private message me if that is possible. 

Is it working for any other applications?

Best,

Seth

View solution in original post

Illias_A_
Beginner
141 Views
I finally tried Samsung Galaxy Tab Pro 8.4 (SM-T320) with Android 6.0 and applications+ADB root access type, it works great and out-of-box. Seems like rooting type/policy/rights managing can harm profiling setup. I'll try to manage it with S4 and notify about any results. Anyway, thank you for all the investigation and help.
Reply