Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Jason_K_3
Beginner
182 Views

SwapChain ResizeBuffer invalid

I have an UnrealEngine v4.9.0 application that I'm running Graphics Monitor 2015 R3.  Initially everything works fine - I'm able to run without issue.  But if I toggle on hmd (stereo) mode, I get the following...

Fatal error: [File:D:\PERFORCE_WORKSPACE\NU_REALITY\UNREAL_ENGINE\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 200] 
SwapChain->ResizeBuffers(1,SizeX,SizeY,GetRenderTargetFormat(PixelFormat),DXGI_SWAP_CHAIN_FLAG_ALLOW_MODE_SWITCH) failed 
 at D:\PERFORCE_WORKSPACE\NU_REALITY\UNREAL_ENGINE\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Viewport.cpp:213 
 with error DXGI_ERROR_INVALID_CALL

If I'm not running Graphics Monitor, I do not get the crash.  Please advise.

Thanks,

Jason

0 Kudos
7 Replies
Seth_S_Intel
Employee
182 Views

Hi Jason, 

Sorry you are running into this issue and thank you for the error message.  Looks like there may be an issue with how GPA is handling hmd mode.  

If possible, could you private message me with frames that have hmd off and on?  This will help us reproduce the issue you are running into.   

Also, could you post your about dialog?  Graphics Monitor -> About

Best,

Seth

 

Seth_S_Intel
Employee
182 Views

Hi Jason, 

I wanted to follow up with you. Are you still having this issue?  Could you post your "about" dialog here?

Best,

Seth

Jason_K_3
Beginner
182 Views

Hi Seth,

Below is my About information.  Additionally, I've been able to narrow down the issue.  If I had Steam (from Valve) running I was getting this issue.  This makes capturing stereo with the Vive difficult (the vrmonitor can run for about 30sec before it notices that Steam has been shutdown).  But to capture stereo with the Oculus, all I needed to do was turn off Steam and I would not get the crash.

Cheers,
Jason

Windows 10 build 10240, 64-bit DEP enabled
Num Processors: 12
Memory: 32689MB
System BIOS: American Megatrends Inc. 1.01 (09/09/2015)
Driver 0:
     Device: NVIDIA GeForce GTX 980 Ti
     Provider: NVIDIA
     Date: 10-18-2015
     Version: 10.18.13.5870
     VendorId: 10de
     ProductId: 17c8
     Stepping: a1
     No support for GPA Instrumentation
Install directory: C:\Intel\INDE\GPA\2015 R3\
Version: 15.3.262022
Current user is in Administrators group: YES
Current Graphics Performance Analyzers 2015 R3 (15.3.262022)
Secure Boot/Trusted Boot is Disabled

Seth_S_Intel
Employee
182 Views

Very interesting. Thank you for the information! 

So if Stream and GPA are running, then Vive crashes with the error message in the OP.  But if Steam is not running and you are using Oculus, everything seems to work fine.  Is this correct?  If so it looks like our injection and vrmonitor may have compatibility Compatibility issues we need to fix. 

I'll add this defect into our backlog and keep you updated.  

Jason_K_3
Beginner
182 Views

If Steam and GPA are running along with my UnrealEngine app and I attempt to go into stereo/hmd mode then my app crashes as noted in the origin post.  It doesn't matter whether I'm using Vive or Oculus headsets.

Seth_S_Intel
Employee
182 Views

Awesome.  Thank you for the clarification. I have submitted the bug and will let you know what the time frame looks like for a fix.  I'll let you know if I have any other questions. 

Best,

Seth

Seth_S_Intel
Employee
182 Views

Hi Jason,  

We have looked into this issue and currently do not have the resources to fix this issue within the next release.  I hope that you can continue profiling with the Oculus. 

While digging I may have found a work around.  Often steam and GPA don't play nicely because they both inject into games.   If you disable the steam overlay, it could solve this issue. 

Let me know if this workaround works for you!

Best,

Seth

Reply