Intel® ISA Extensions
Use hardware-based isolation and memory encryption to provide more code protection in your solutions.
1064 Discussions

Intel Intrinsic Guide won't run on my XP SP2


I downloaded the Intel Intrinsic Guide - sounded like a cool idea - maybe even something like that for all the instructions would be cool too... Though I'm not sure how it's actually implemented, since it won't run on my PC.

I basically just downlodaed it, unzipped it, and tried double-clicking on the "Intrinsics Guide for Intel AVX.exe" file. Nothing (obvious) happens.

If I do it close enough to a refresh while running Task Manager, I can see that "javaw.exe" opens for a moment, then is gone again. (I just kept clicking the Intrinsics exe over and over to get it, as I suspected the reason I wasn't getting anything at first was that it was disappearing before the Task Manager got around to refreshing)

Anyway - I'm not sure what else to say except that I'm running XP SP2, all patched to date. I happen to have JRE build 1.6.0_03-b05 installed, maybe that's not the right version or something...? I have lots of other stuff installed, of course... but nothing else I can think of that might be relevant...

I also checked the event logs, but nothing relevant there.

Any idea how I might get it to run, or at least track down the cause of the failure...?

Thanks :)
0 Kudos
3 Replies


The Intrinsics Guide doesn't seem to run inJRE build 1.6.0_03-b05. Can you try updating your JRE and run it again? It is working on my JRE build 1.6.0_05-b13. Please let me know if that resolves the issue.



Thank you very much for your reply, and for the suggestion. :) I finally got a chance to look at this again, and...

I tried first going to and doing a "normal" java update, which apparently installed 1.6.0_05-b13, and then tried running the Intrinsics Guide, but no apparent difference.

When I tried running the java "verifier" that Sun has, it said:

"You have the recommended Java installed (Version 6 Update 5)."

I wasn't sure at the time if that was what I wanted or not (the Sun java pages and the whole java system/files/layout/etc seems excessively complicated) - so I looked for the latest available one, and found, downloaded and installed the JRE 1.6.0_10-b14, and again tried running the Intrinsics Guide, but still nothing.

When I ran the verifier with this one installed, it said:

"You have the recommended Java installed (1.6.0_10-beta)."

So I still wasn't sure... Digging a bit deeper and actually checking the java version manually, I did find that the first update I'd installed was the 1.6.0_05-b13, and the next was the 1.6.0_10-b14... So not having any other ideas, I restarted my PC... but after the reboot, when I try to run the Intrinsics Guide... it still doesn't appear to do anything at all.

I would very much appreciate any other thoughts or suggestions on how I might get this to work.

Thanks again very much for your time, and assistance! :)

Same problem -Intel Intrinsic Guide doesn't run. It appears to freeze when progress bar hits 100%.
Same problem on two different Windows 7 systems.