Intel® ISA Extensions
Use hardware-based isolation and memory encryption to provide more code protection in your solutions.

Intel sde 9.7 does not work on my pc

Pedro122h
Beginner
2,767 Views
this new version of the emulator does not work on my pc when i try to run a program nothing happens.
Version 9.0.0 works correctly but this version no longer works.
Cpu: amd athlon x2 250
windows version: windows 10 21H2 64 bits
0 Kudos
9 Replies
AdyT_Intel
Moderator
2,740 Views

We do not test Intel SDE on AMD CPU, but it should be working.

This might be a permissions issue when extracting the files with cygwin tar or other utility.

0 Kudos
Pedro122h
Beginner
2,732 Views
I am using WinRAR to extract the program and it did not give me problems with the previous version.

 

0 Kudos
AdyT_Intel
Moderator
2,724 Views

Can you provide more information?

A few checks that can be done is to run:

% sde -p -pause-tool -p 1 ........ -- app

This should give information if pin started the process correctly, and if this is successful you can try running:

% sde -p -xyzzy -p -mesgon -p log_win ...... -- app

This will provide pin messages in the pin log file.

 

0 Kudos
Pedro122h
Beginner
2,710 Views


here are the log files i got, i also noticed that no intel sde process appears in task manager.
so I think the program closes a few seconds after starting.

0 Kudos
MICHAEL_G_Intel1
Employee
2,693 Views

Hi

The log seem fine.

Can you please attach the application here and the exact command line that you are using?

0 Kudos
Pedro122h
Beginner
2,670 Views
sde -nhm -- "C:\Users\pedro\Downloads\pcsx2-v1.7.3236-windows-64bit-SSE4-Qt\pcsx2-qtx64.exe" 
0 Kudos
MICHAEL_G_Intel1
Employee
2,646 Views

Ok, i tried running it with 9.7 and it works fine

please make sure that you unzip correctly the kit

and that all permissions are fine

I used 7-zip but you can use others apps as well

0 Kudos
Pedro122h
Beginner
2,621 Views


The problem doesn't seem to be permissions.
I also realized that the log that the previous version throws is longer and more detailed.
For some reason it seems that this version does not start properly.

0 Kudos
MICHAEL_G_Intel1
Employee
2,615 Views

According to the log the version does start properly

Do you see the application gui start? or does it start and gets stuck?

In my pc the application starts fine with sde.

Michael

0 Kudos
Reply