Community
cancel
Showing results for 
Search instead for 
Did you mean: 
superstatic
Beginner
85 Views

Can't find file ipps.lib (but IPP is disabled)

Hi guys.

I have a VS2010 solution using Parallel Studio in which I have disabled IPP under properties->intel performance libraries ("Use IPP") for each project but the linker is still telling me it can't find ipps.lib.

Any idea what might be causing this?

Thanks a lot!
0 Kudos
4 Replies
Chao_Y_Intel
Employee
85 Views


Hi,

Are you using Parallel Studio 2011? Please check the following two settings:

1) Does the code include any IPP head filer (e.g ipp.h), and project prosperity>>C/C++>>Preprocessors>>Preprocessor Definitions include definition like '_IPP_PARALLEL_DYNAMIC, If so, please remove it.

2) In project prosperity>>Linker>> Input>>Additional Dependencies, does it include any IPP libraries?

Thanks,
Chao

superstatic
Beginner
85 Views

Thanks for the quick reply. Yeah, it's Parallel Studio 2011 which I'm using in Visual Studio 2010. I don't have these things set. I've just taken my existing project and selected "Use Intel" on the solution without making any additional changes.

I just turned off "Enabled Multiply Matrix Call" (which was set to yes by default) and this let 4 out of the 16 projects in the solution build successfuly. I have no idea why the others keep asking for ipps.lib.
Ma
Chao_Y_Intel
Employee
85 Views

Hi,

Would it be posssible to attach a sample project, so we can have a check?

Thanks,
Chao
Naveen_G_Intel
Employee
85 Views

Hi,

Reason could be because of linking library is not pointing to right directory. It should be

/Composer/IPP/lib/ia32

I was getting same error while running IPP sample with IPS 2011, working after setting right path as mentioned above.

Regards,

Naveen Gv

Reply