Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Kryten67
Beginner
124 Views

Cryptography 8.2

I have the main IPP installation package (Windows):

w_ipp_8.2.2.208 (and .148)

The latest cryptography package is

w_ccompxe_crypto_ipp_8.2.2.221_intel64

This package will not install, because it requests to install IPP 8.2.2.221 first ... but I cannot find that anywhere

 

Please help

0 Kudos
8 Replies
Chao_Y_Intel
Employee
124 Views

Hello, 

have you login in the registration center to download the package: 
https://registrationcenter.intel.com/

After you login in, select the "Cryptography for Intel® Integrated Performance Primitives for Windows*, you will find both versions there. 

or, if you just click the download link in the registration email,  and can find the old package by click:  

"Additional downloads, latest updates and prior versions."

Thanks,
Chao

Kryten67
Beginner
124 Views

The problem is not finding the latest IPP-cryptography package, I have that (v221) -- the problem is finding the latest IPP core package -- the latest appears to be v208 (Update 2).  Crypto-221 will not install without core-221 being available...

Chao_Y_Intel
Employee
124 Views

Hi, 

Do you have a valid IPP license, or Intel parallel studio license for Windows?  If so, you can login into the 
https://registrationcenter.intel.com/

and download it from the "Intel® Integrated Performance Primitives for Windows*"  products. 

btw, Intel IPP is also offering some free community edition here: software.intel.com/nest here, but only the latest IPP version (IPP 9.0) is available 

Thanks,
Chao

Kryten67
Beginner
124 Views

Yes, I have several IPP licenses purchased for our organization.

The download center does NOT have 8.2.2_221 version of the core IPP library (only the crypto lib).

The most recent build of the core IPP library available at the registration-center is 8.2.208

The registration-center needs to be updated to have the 221 build posted.

Chao_Y_Intel
Employee
124 Views

Hello, The crypto file w_ccompxe_crypto_ipp_8.2.2.221 is for Composer XE 2015 update 4(2015.4.221). w_ccompxe_crypto_ipp_8.2.2.208 for the standalone IPP 8.2 update 2 release (8.2.2.208). Both crypto_ipp_8.2.2.221 and 8.2.2.208 are the same IPP 8.2 update 2 release, but they different builds for the different packages. If you are using the standalone package(8.2.2.208), please just use the w_ccompxe_crypto_ipp_8.2.2.208 there. Sorry for the confusion there. Thanks, Chao
Chao_Y_Intel
Employee
124 Views

Hello, The crypto file w_ccompxe_crypto_ipp_8.2.2.221 is for Composer XE 2015 update 4(2015.4.221). w_ccompxe_crypto_ipp_8.2.2.208 for the standalone IPP 8.2 update 2 release (8.2.2.208). Both crypto_ipp_8.2.2.221 and 8.2.2.208 are the same IPP 8.2 update 2 release, but they different builds for the different packages. If you are using the standalone package(8.2.2.208), please just use the w_ccompxe_crypto_ipp_8.2.2.208 there. Sorry for the confusion there. Thanks, Chao
Chao_Y_Intel
Employee
124 Views

Hello, The crypto file w_ccompxe_crypto_ipp_8.2.2.221 is for Composer XE 2015 update 4(2015.4.221). w_ccompxe_crypto_ipp_8.2.2.208 for the standalone IPP 8.2 update 2 release (8.2.2.208). Both crypto_ipp_8.2.2.221 and 8.2.2.208 are the same IPP 8.2 update 2 release, but they different builds for the different packages. If you are using the standalone package(8.2.2.208), please just use the w_ccompxe_crypto_ipp_8.2.2.208 there. Sorry for the confusion there. Thanks, Chao
Kryten67
Beginner
124 Views

Ah, that was confusing!

 

Thanks for the clarification

Reply