Intel® Integrated Performance Primitives
Community support and discussions relating to developing high-performance vision, signal, security, and storage applications.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
6593 Discussions

Error decoding H.264 using fast CABAC decoding

Pascal_Binggeli
Beginner
148 Views
Hello

[EDIT: i'm sorry that no content was provided in the initial post - there must have a compatibility issue with IE9 RC.]

The problem I'm experiencing is that using a specific MP4 file containing a H.264 video stream, the H.264 video decoder generates an access violation. The MP4 file has been created using handbrake (and I guess x264 video encoder internally.)

While decoding the bitstream, the decoder incorrectly identfies the type of a macrobloc and access memory ouside the buffer allocated for the bitstream.

The error disapears after setting the symbol CABAC_MAGIC_BITS to 0 in the file umc_h264_bitstream.h.

I'm using the IPP 7.0.2 with corresponding IPP base classes.

Do you have any idea about this problem ? Do you need the video file for reproduction ?

Thanks for your time,
Pascal

0 Kudos
3 Replies
PaulF_IntelCorp
Employee
148 Views
Hello Pascal,

No details in your post. If you provide some details we might be able to help out.

Regards,

Paul
Pascal_Binggeli
Beginner
148 Views
Sorry,

I've edited the original message.

Thanks,
Pascal
PaulF_IntelCorp
Employee
148 Views
Hello Pascal,

The upcoming 7.0.4 release contains some fixes that may address the problem you are citing above. Please check it out to see if it resolves your issue. The release should appear within the next two weeks. If you are a registered user with an up-to-date license you'll receive an email announcing the release update.

Paul
Reply