Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Mark_Rubelmann
Beginner
65 Views

Installation problem on Windows Vista

I'm trying to install the 32 bit and 64 bit versions of IPP on a machine running 64 bit Windows Vista Ultimate. I think I did all the steps outlined in http://software.intel.com/en-us/articles/how-to-install-the-intel-ipp-70-library-on-windows/ and IPP itself seems to be installing correctly but it's not installing all of the compiler libraries. If I run the 32 bit installer first I get C:\\\\Program Files (x86)\\\\Intel\\\\ComposerXE-2011\\\\compiler\\\\lib\\\\ia32 but then when I run the 64 bit installer, the corresponding intel64 directory doesn't show up. I tried uninstalling and reinstalling them in the reverse order. That time I got intel64 but not ia32. I'm also not getting both versions of the compiler redistributables in C:\\\\Program Files (x86)\\\\Intel\\\\ComposerXE-2011\\\\redist\\\\[platform]\\\\compiler. I've successfully installed both versions on multiple Windows 7 boxes but lovely Vista isn't working. Is this a known problem? Is there any way to fix it? I posted here since it's the IPP installer but should this be on the compiler forum instead?

Thanks,
Mark
0 Kudos
5 Replies
Mark_Rubelmann
Beginner
65 Views

I figured out a workaround for the problem:

- Install the 32 bit version.
- Copy C:\\Program Files (x86)\\Intel\\ComposerXE-2011\\compiler\\lib\\ia32 and C:\\Program Files (x86)\\Intel\\ComposerXE-2011\\redist\\ia32\\compiler to somewhere else.
- Uninstall 32 bit.
- Install 64 bit.
- Reinstall 32 bit.
- Move copied files back to their rightful homes.

What a pain! Oh well, at least it works.

-Mark
Gennady_F_Intel
Moderator
65 Views

Mark, Could you provide us the package ID of IPP you are trying to install? You can find this info in the ..\ComposerXE-2011\Documentation\ ippsupport.txt.
--Gennady
Nikolay_L_Intel
Employee
65 Views

Hello Mark,

Could you kindly send a log file located%temp%/ComposerXE2011.Log at your machine?

We did not discover something similar before.
Right now we are trying to reproduce the problem in our test lab.

I will return to you withrecommendations as soon as we detect a root cause.

I have subscribed on this topic, so please contact me if you have additional questions.

Thank you,
- Nikolay

Mark_Rubelmann
Beginner
65 Views

Package ID: w_ipp_7.0.3.175 w_ccompxe_2011.3.175
Gennady_F_Intel
Moderator
65 Views

Thanks Mark. I will ask to investigate this problem our install engineer and we will back asap. Regarding attaching process - we have the article how to attach the file to the forum see the details here.
--Gennady
Reply