Community
cancel
Showing results for 
Search instead for 
Did you mean: 
TatKin_T_Intel
Employee
72 Views

simple_player failed to execute and complaining libiomp5md.dll not found

I tried to compile simple_player with IPP Package ID: w_ipp-samples_p_7.0.2.048, during the compilation, i get the below linking info as highlighted, but it returns 0 errors and warnings.

But when simple_player.exe is executed, i get an error msg The ordinal 858 could not be located in the dynamic link library libiomp5md.dll. I searched the laptop, theres no such file as libiomp5md.dll resided in the harddrive. Are there any pre-requisites for w_ipp-samples_p_7.0.2.048?

35>simple_player.cpp

35>Linking...

35>LINK : ..\\..\\_bin\\Win32\\debug_ascii\\simple_player.exe not found or not built by the last incremental link; performing full link

35>Build log was saved at "file://c:\\Users\\wlim9\\Desktop\\7.0.2.048\\w_ipp-samples_p_7.0.2.048\\ipp-samples\\audio-video-codecs\\_bin\\Win32\\debug_ascii\\simple_player\\BuildLog.htm"

35>simple_player - 0 error(s), 0 warning(s)

========== Rebuild All: 35 succeeded, 0 failed, 0 skipped ==========

need some help/direction on how to resolve this error. can someone render a hand/suggestion?

thanks.

0 Kudos
1 Reply
Gennady_F_Intel
Moderator
72 Views

since the version 7.0, IPP is bundled with Composer XE, libiomp5md.* binary can be found here:

\redist\ia32\compiler\ ? DLL

\compiler\lib\ia32\ ? LIB

So, please add these path to the your system path and try to launch the executable again.

Reply