Community
cancel
Showing results for 
Search instead for 
Did you mean: 
piquini
Beginner
49 Views

problem in installing parallel siesta

I am trying to install the parallel version of the Siesta code in my Core 2Quad Intel Xeon machine.

For that I need to set an arch.make file, that I show below

It stops because apparently it cannot recgnize the format of a subroutine. See the error below

***************************************************************************

/opt/intel/impi/3.2.2.006/bin64/mpiifort -o kind_explorer kind_explorer.o
ipo: warning #11009: file format not recognized for /opt/intel/impi/3.2.2.006/lib64/libmpi.so
ipo: warning #11009: file format not recognized for /opt/intel/impi/3.2.2.006/lib64/libmpiif.so
ld: skipping incompatible /opt/intel/impi/3.2.2.006/lib64/libmpi.so when searching for -lmpi
ld: skipping incompatible /opt/intel/impi/3.2.2.006/lib64/libmpi.a when searching for -lmpi
ld: cannot find -lmpi
make[2]: *** [kind_explorer] Error 1
make[2]: Leaving directory `/home/piquini/piquini/codes.dir/siesta-3.0-b/Obj/MPI'
make[1]: *** [Interfaces.f90] Error 2
make[1]: Leaving directory `/home/piquini/piquini/codes.dir/siesta-3.0-b/Obj/MPI'
make: ** [libmpi_f90.a] Erro 2

***************************************************************************

The kind_explorer.f90 file, for which this error appear is showwd below.

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

program kind_explorer

!
! Simple program to detect the kinds of real numbers
! Standard output: one or two integers, corresponding
! to the "single" and "double precision"
!
integer, parameter :: sp = selected_real_kind(6,34)
integer, parameter :: dp = selected_real_kind(15,300)

integer, parameter :: default_p = kind(1.0)

if (sp > 0) then
if (dp > 0) then
if (sp /= dp) then
write(unit=*,fmt=*) sp, dp
write(unit=0,fmt=*) "Single: ", sp, " Double: ", dp
else
write(unit=*,fmt=*) dp
write(unit=0,fmt=*) "In your computer sp=dp"
endif
else
write(unit=*,fmt=*) sp
write(unit=0,fmt=*) "Your computer does not have double prec reals!"
endif
else
if (dp > 0) then
write(unit=*,fmt=*) dp
write(unit=0,fmt=*) "Your computer does not have single prec reals!"
else
write(unit=0,fmt=*) "Your computer's real number system is weird"
endif
endif
write(unit=0,fmt=*) "Your computer's default precision real kind is ", default_p


end program kind_explorer

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

0 Kudos
5 Replies
TimP
Black Belt
49 Views

Do you have ifort environment variables set correctly? ifort isn't included with Intel MPI (unless you install the Cluster Tools Compiler Edition).

What do you get for

mpiifort -V

?

piquini
Beginner
49 Views

Hi Tim18,

thanks for your answer to my post.

Well, I bought the Intel Cluster Toolkit.

the result of mpiifort -V is

Intel Fortran Compiler Professional for applications running on IA-32, Version 11.1 Build 20091012 Package ID: l_cprof_p_11.1.059
Copyright (C) 1985-2009 Intel Corporation. All rights reserved.

Looking at this, it seems I have a 32 bit version installed but my machine is 64 bit. Am I right on this?

TimP
Black Belt
49 Views

Yes, this is the 32-bit compiler. You should have complete installations for development and execution of both 32- and 64-bit applications. They will not work when mixed together, as it seems you have done.

For 64-bit environment, typical bash setting:

source /opt/intel/Compiler/11.1/059/bin/ifortvars.sh intel64

source /opt/intel/impi/3.2.2/bin64/mpivars.sh

For 32-bit, change intel64 to ia32, and bin64 to bin. You probably don't want any 32-bit stuff, unless you are developing an application to run on a pure 32-bit cluster.

If you wish to pursue this further, the Clusters and HPC forum is appropriate.

piquini
Beginner
49 Views

Hi Tim18,

thanks again. I will install it correctly and try again.

However, I was looking at the Siesta mailing list, and it seems that noboby was able to compile the Siesta code using the version 11 of fortran compiler. There are some bugs related to the FoX library etc.

Anyway, I will try it again.

Thanks you very much.

Paulo

TimP
Black Belt
49 Views

Problems with FoX have been discussed on the compiler forum. It would indicate there if any were solved in the latest update.