Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
173 Views

Intel optane Memory / HDD Problem

Jump to solution

Hi, I’m super new to all of this so please bear with my confusion about basic things. I’ve had this computer for about three years now, and I’ve never had any issues with it. Recently we had a power outage for a second while I was using the PC and it had trouble turning on. It got stuck in a “Preparing Automatic Repair” boot loop, after which it just turned off, it never took me to the blue screen where I could access advanced options. I could only access my UEFI, and after messing around with the settings there I finally managed to get it to boot again but the problem now is with my HDD and Intel Optane. when I set SATA mode to “intel RST with Optane”, the system does not read my HDD at all, just my SSD (From which Windows boots from) but when I change it to AHCI though, both my SSD and HDD drives show up fine, but Intel Optane Memory does not work at all. I didn't make any major changes to the hardware besides removing and putting back the battery on the motherboard to reset the CSM and unplugging and replugging SATA cables. Also, when I reset to default settings on UEFI, it changes it to AHCI but Intel Optane still doesn't work. How do I get it back to normal? With both drives and Intel Optane working smoothly?

 

Specs:

CPU: Intel(R) Core™ Processor i7-8700K 3.70GHZ 12MB Intel Smart Cache LGA1151 (Coffee Lake)

 

256GB WD Black Series PCIe NVMe M.2 SSD

 

HDD: 1TB SATA-III 6.0Gb/s 32MB Cache 7200RPM HDD

 

MEMORY: 16GB (8GBx2) DDR4/3000MHz Memory Module

 

MOTHERBOARD: GIGABYTE GA-Z370 HD3 ATX, USB 3.1, 3 PCIe x16, 3 PCIe x1, 6 SATA3, 1 M.2 SATA/PCIe

 

 

0 Kudos

Accepted Solutions
Highlighted
Super User
105 Views
  1. I'm glad that Optane acceleration works now.
  2. The only drawbacks to use the Intel RST application is that it will be not supported (i.e. new version will be not released).
  3. When trying to use the new application (from Microsoft Store), did you updated the RST drivers as explained in my post above para. 13?

 

Leon

 

View solution in original post

0 Kudos
3 Replies
Highlighted
Super User
105 Views
  1. Your Optane memory is probably still assigned to the HDD. My suggestion is first to clean the Optane module:
  2. Open Windows PowerShell(Admin) or Admin Command Prompt. In the window write the following commands (click enter after each command).
  3. diskpart
  4. list disk (you should see list of three disk labeled disk 0, disk 1, disk 2).
  5. Find the Optane memory module in the above list. It should have size 16 GB or 32 GB (depending of your Optane Memory size).
  6.  From the diskpart prompt you will need to select a disk disk number (for instance, if the Optane Memory 32GB + drive is Disk 2, you would type select disk 2) and press EnterDiskpart Erase/Clean will permanently erase/destroy all data on the selected drive. Please be certain that you are erasing the correct disk. 
  7.  From the diskpart prompt, type clean all and press Enter. The Optane Memory is now erased and the old enablement is not active any more.
  8.  Close out of the Command Prompt.
  9. I can suggest you to reinstall the Optane Memory software. FYI, the Intel Optane Memory application has reached End of Life and is replaced by Intel Optane Memory and Storage Management that can be downloaded from Microsoft store. Please see more information here.
  10.  You should verify that the SATA mode in Bios setting is set to "Intel RST premium ….", rather than AHCI. In order to change the SATA mode without corrupting Windows, you should enter BIOS after setting Windows boot mode to SAFE. After rebooting to Windows after changing the SATA mode, you may disable the SAFE mode and boot in Normal mode.
  11. You should prepare minimum 5MB of unallocated space in the end of the drive being accelerated.
  12. Open Apps & Features (Windows Settings) and uninstall the currently installed Optane Application, Optane Extension and Intel RST (if any)
  13.   Download Intel RST Driver and unzip it on your drive. Right click on iaStorAC.inf and select install from drop down menu. Reboot your computer.
  14. Download from Microsoft Store and install the Intel Optane Memory and Management.
  15. Now enable Optane Acceleration. Follow Intel Optane Memory Installation Guide, Section 3.

 

Leon

 

0 Kudos
Highlighted
Beginner
105 Views

Hey - Thanks so much! This seems to be working but there's just one problem left, I cannot enable acceleration. When I click Enable Intel Optane Memory, check the box to erase data on the memory module and click enable, some rings appear to show a process in progress but the nothing happens. The status still shows as "Disabled." I tried restarting and everything but to no avail. What do I do from here? Thanks so much again for your help

 

Edit: I finally got it to work using the older Rapid Storage Technology Application instead of the newer one on the microsoft store. I understand that it has been discontinued, are there any drawbacks to continue using this application as opposed to the newer one?

0 Kudos
Highlighted
Super User
106 Views
  1. I'm glad that Optane acceleration works now.
  2. The only drawbacks to use the Intel RST application is that it will be not supported (i.e. new version will be not released).
  3. When trying to use the new application (from Microsoft Store), did you updated the RST drivers as explained in my post above para. 13?

 

Leon

 

View solution in original post

0 Kudos