Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
156 Views

Intel optane memory installation issue

Jump to solution

I have installed Intel Optane module into PC, setup drivers and management soft from Microsoft store. When I open Intel optane management software there is an error that Intel Optane cant work with AHCI. So, I'm going into BIOS to change SATA Controller mode.

 

BIOS Settings I've made are as follows:

SATA Controller mode: Intel Optane Premium ..........

Legacy RST Option OROM: Enabled

Windows features: Windows 8/10

CSM Support: Disabled

I have not found the option for hardware remapping for M.2 port (it was recommended in intel video regarding intel optane installation) though.

 

When I restart my PC (with abovementioned settings) and Intel Optane module in Boot Option#1 it just dont start and gettng me to the BIOS. If I restart my PC (with abovementioned BIOS settings) and HDD in Boot Option#1 it getting a BSOD (#INACCESIBLE BOOT DEVICE).

 

PC SPECS:

Processor: i7-7700K

Motherboard: Gigabyte GA-Z270-HD3

0 Kudos

Accepted Solutions
Highlighted
Super User
61 Views

The system report that you attach shows that you are legacy boot. We cannot help you with how to change it as each manufacturer's bios is different.

 

Plus, you have to have a GPT partition to boot. If you have a MBR partition, you have to convert to GPT (using MBR2GPT). Then, on the reboot, you have to go into the bios and make the change from legacy to UEFI.

 

Then, you have to allocate a small partition on the end of your boot drive.

 

To be sure we are on the same page, what is the model number of you Optane module?

 

Doc

 

Doc (not an Intel employee or contractor)

View solution in original post

0 Kudos
7 Replies
Highlighted
Super User
61 Views

Download, run, and save the results of this utility as a text file:

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility

 

Then ATTACH the text file (using the paperclip under the toolbar).

 

Doc

 

Doc (not an Intel employee or contractor)
0 Kudos
Highlighted
Beginner
61 Views

Done

0 Kudos
Highlighted
Super User
61 Views

You need to set your bios mode to UEFI.

 

Doc

 

Doc (not an Intel employee or contractor)
0 Kudos
Highlighted
Beginner
61 Views

How can I do that? I dont see such option or anything similar.

It supposed to be UEFI by default, isnt it?

 

Now when CSM is disabled my PC getting me to the BIOS no matter what is in boot option. Seems like it cannot boot properly with CSM disabled.

The BIOS settings were similar to the attached screen (got it from Gigabyte manual at their website).

0 Kudos
Highlighted
Super User
62 Views

The system report that you attach shows that you are legacy boot. We cannot help you with how to change it as each manufacturer's bios is different.

 

Plus, you have to have a GPT partition to boot. If you have a MBR partition, you have to convert to GPT (using MBR2GPT). Then, on the reboot, you have to go into the bios and make the change from legacy to UEFI.

 

Then, you have to allocate a small partition on the end of your boot drive.

 

To be sure we are on the same page, what is the model number of you Optane module?

 

Doc

 

Doc (not an Intel employee or contractor)

View solution in original post

0 Kudos
Highlighted
Beginner
61 Views

MEMPEK1F032GA01

0 Kudos
Highlighted
Super User Retired Employee
61 Views

Also, why to you have the Legacy RST OpROM enabled? You want to be using the UEFI RST OpROM.

 

My take on where you stand? You are going to have to completely blow away your Windows installation and do a proper UEFI installation (just converting the partition to GPT isn't good enough). You are also going to have to reserve space (~15MB) at the end of the drive for the use of Optane. Here is process:

 

  1. Create UEFI bootable Windows installation flash disk. Use Microsoft's Windows Media Creation Tool (a brand new version was released late yesterday for the 2004 (20H1) build).
  2. Configure the BIOS for UEFI boot. Disable everything Legacy.
  3. Boot from the flash disk in UEFI mode.
  4. Very Important: When you come to the page where you select the partition for Windows installation, delete *all* existing partitions on the drive.
  5. Very Important: Select the Unallocated Space entry (should now be only entry it shows for the disk drive) and then select Install.
  6. Note: Steps 4 & 5 together will result in the Windows installer deleting the existing partition table and creating a new one. It will also create appropriate recovery partitions, etc.
  7. Continue with Windows installation and, once you've booted into your new Windows installation, install any and all device drivers packages that you need (rebooting when appropriate).
  8. Right-click on the Windows Start button and select Disk Management. In this applet, select the partition that Windows was installed to (the one marked as having drive letter C) and shrink this partition by ~15MB.
  9. Exit the tool. You are now done and ready to activate the Optane module.

 

Hope this helps,

...S

0 Kudos