Intel® Optane™ Memory
Support for Issues Related to Intel® Optane™ Memory
Want to learn how Intel® Optane™ Memory can help your business? Talk to our Expert!

Looking for our RealSense Community? Click HERE

The Intel® SSD Toolbox and Intel® Data Center Tool are now End-Of-Life, see for more information and replacements tools here
1327 Discussions

Windows Update and Optane storage driver BSOD. Can we replace failed system driver?


ACER Swift ​SF315-52 series. Intel M10 Optane && hard drive combo...

Trying to repair mom's PC. I think maybe a system update broke it. I created a reddit thread and reached out to multiple support options. All of them want me to reinstall the OS. Some say I won't lose data, but will lose apps. I would rather not lose anything. It seems like maybe the wrong optane driver was installed? It was working and then she told me that overnight it broke, leading me to suspect Windows updates

According to mom, she tried to use the computer last night and it kept restarting. Sometimes it gives a blue Recovery screen an there's a menu See advanced repair options. I've tried a number of things from the repair options but it seems to keep BSOD and rebooting.

Can we create a boot disk and fix the stoarge driver for this error? Anyone experienced with these Optane repairs? I do not want to lose installed applications or data.

Safe mode reboots. Safe mode with the command prompt reboots.  PAGE_FAULT_IN_NON_PAGED_AREA

What failed:IaStorA.sys


Also another screen




What failed:IaStorA.sys

0 Kudos
9 Replies

un install the windows store app, then uninstall the drivers from control panel should say ssd tool box and memory and storage tool. anything with intel drivers for storage basiclly. then goto here.    download that and start over, it should re install the windows store app. well goodluck

0 Kudos

I am not sure if you got it above. The system just blue screens whatever I do. There is no going to the windows store, uninstalling apps, etc.

I am wondering details about Optane. Is the boot sector written to the Optane SSD. Can we write another boot sector to the Optane SSD, without reinstalling windows?

Can we otherwise instead write a new boot sector to the hard disk, without reinstalling windows?



0 Kudos

Hello, kallisti.

Thank you for contacting Intel® Memory and Storage support.

As we understand, you needed assistance with your Intel® Optane™ Memory Series in your ACER Swift ​SF315-52 series. If we inferred correctly and based on the information you provided. We advise you to contact your OEM Acer* to get your system check and to return your system to factory defaults if possible. Remember to clean your Optane memory after this process is done, and to reactivate the Optane acceleration.

Please take into consideration that this issue could be related to the hardware, BIOS and software configuration in your system, we advise you to make a backup of your information before taking your PC to your OEM repair center.

We will proceed to close this inquiry now.

If you need further assistance regarding any other Intel® product, please post a new question.

Best regards,

Josh B.
Intel® Customer Support Technician
A Contingent Worker at Intel®

0 Kudos
Super User

Hi @kallisti 

1. Since you don't have better choose if you wan't, try the following Procedure (I didn't try it and I'm not sure if it will help):

2. Insert  Windows Installation USB into USB slot. If you don't have one, prepare it using Microsoft Media Creation Tool. 

3. Power On your laptop and enter to BIOS settings.

4. Change the SATA mode to AHCI.  Save the settings and exit from Bios. Boot into installation USB.

5. Select your language preferences and click/tap on Next

6. Click/tap on Repair your computer at the bottom. 

7. Click/tap on Troubleshoot

8. Click/tap on Advanced options.

9. Click on Command Prompt 

10. In the Command Prompt write the following command: bcdedit /set {default} safeboot minimal and press enter to execute this command

11. Close the Command Prompt window by clicking the X in the upper right corner of the Command Prompt window.  Remove the Installation USB.

12. Select Continue and sign in to Windows

13. While in Windows (if you will get successful boot into Windows), press Windows key + r. Run msconfig

14. Chose Boot tab and uncheck Safe boot.  Reboot your system. 




Thanks @LeonWaksman ,

If I understand the process correctly you are describing allows to boot a windows system from USB, recognizing the hard disk as the installation area. Looks like there's some documentation here:


I will give it a shot!


Regarding Intel's support response above. The system is just a little over 1 year old, so slightly out of warranty. Acer hasn't been able to help.

0 Kudos
Super User

Hi @kallisti 

 The main thing I want to do is to change SATA mode from "Intel RST Premium..." to AHCI. It have to be done while Windows is set to SAFE boot mode, otherwise you will cause to further boot corruption. During this SATA mode change, Windows should load the correct driver (I hope ). Could be better is not to remove the USB stick during boot to Windows.





I took the optane module out, then i wrote a backup image for the SATA drive. I switched the bios setting. I turn the device on. It goes through an "Automatic Repair" process. Then says AR couldn't repair the PC. Mentions a log file C:\WINDOWS\System32\Logfiles\Srt\SrtTrail.txt.

Then I chose Advanced options > Troubleshoot > Advanced options (lol) > Command Prompt. This puts me at X:\windows\system32> on the command prompt.

bcdedit /set {default} safeboot minimal

> The operation completed sucessfully.

Then I closed the prompt chose continue to boot Windows 10. But it reboots after choosing and starts Diagnosing and Automatic Repair screen with Advanced options again.


So then I chose Advanced options > Troubleshoot > Advanced options (lol) > Command Prompt. This puts me at X:\windows\system32> on the command prompt.

I naviaged to c:\ to view SrtTrail.txt above.  type SrtTrail.txt displays the file contents. See a number of Test Performed. All say completed sucessfully. Checking for pending package install say completed sucessfully but has Error code = 0x4 where all others have Error code = 0x0.


I have not yet tried to boot from a USB stick. The BSOD behavior has left. I think there must be a way to repair the bootsector or whatever is causing the startup issue. Because filesystem appears intact and BSOD is not happening with Optane removed. But I'm not a Windows tech / engineer so not familiar with the process.


Will bcdedit process behave differently with USB?


Do I need a specific windows image to match installed version of Windows 10? Or will latest release work?


0 Kudos
Super User

I would use USB stick with Windows Installation Media (prepared with Microsoft Media Creation Tool). 




0 Kudos

@LeonWaksman Finally got around writing the USB drive. But unfortunately command did not allow the computer to boot.

It's pretty frustrating considering that I see files on the C:\ drive from the command prompt.

0 Kudos