Intel® Optimized AI Frameworks
Receive community support for questions related to PyTorch* and TensorFlow* frameworks.

Use GPU for TensorFlow

Fer_Colabella
Beginner
1,960 Views

Hi, I have an Intel I7 (11th gen) with an Intel Iris Xe 8 Gb GPU and I can't seem to use it to train artificial neural networks in VSCode. Can anyone help?

0 Kudos
5 Replies
AthiraM_Intel
Moderator
1,859 Views

Hi,


Thank you for posting in Intel Communities.


We are checking on it internally, will get back to you with an update.



Thanks




0 Kudos
YuningQiu_Intel
Employee
1,755 Views

Hello, may I ask what version of TensorFlow you are using? And are you using Intel Extension for TensorFlow at the same time? 

0 Kudos
Fer_Colabella
Beginner
1,750 Views
Hello!
I'm using the 2.14.0 version of TensonFlow and 2.1.0 version of PyTorch. I didn't know about the existence of Intel Extension for Tensorflow, could you tell me the proper name to look for in the marketplace of VSC?
Thanks!
0 Kudos
YuningQiu_Intel
Employee
1,717 Views

Hello, 

 

Sorry, currently Intel Extension for TensorFlow is not available on VSC. (Intel® Extension for TensorFlow is a deep learning extension plugin based on TensorFlow interface, aiming to bring Intel CPU or GPU devices into TF open source community for AI workload utilization and  acceleration. ) Therefore, training neural network on Intel GPU with TF might not functional on VSC. We have plan to add this support for Windows users in the future https://www.intel.com/content/www/us/en/developer/articles/system-requirements/intel-oneapi-ai-analytics-toolkit-system-requirements.html

 

Thanks!

0 Kudos
YuningQiu_Intel
Employee
1,315 Views

We hope the information above is helpful to you. We will close this ticket.

If you have any further questions, please open a new thread. Many thanks!

0 Kudos
Reply