Community
cancel
Showing results for 
Search instead for 
Did you mean: 
yao__ss
Beginner
492 Views

In Ubuntu 16.04, how can I enable SGX in software controlled Mode.

Just as the title. when i use sgx_cap_enable_device() to enable SGX in ubuntu 16.04, I always get the error "undefined reference to 'sgx_cap_enable_device'"(when I debug). I hope someone could help me.  

0 Kudos
1 Reply
Hoang_N_Intel
Employee
492 Views

Please refer to this documentation page https://software.intel.com/en-us/articles/properly-detecting-intel-software-guard-extensions-in-your...

You need to make sure that the BIOS setting is configured with "Software Controlled" option first before making the call to  sgx_enable_device() or sgx_cap_enable_device()

Reply