Community
cancel
Showing results for 
Search instead for 
Did you mean: 
72 Views

Intel SGX PKD and yum updates not working

HI,

   I am currently using the Intel SGX PDK dev board (https://designintools.intel.com/Intel_Data_Center_Platform_Developers_Kit_p/q6uidcsgxpdk.htm) - a redhat linux server 7.3 board. The first few things to try is to get updated/new software for the board. Am new to redhat and yum (as opposed to ubuntu) and am having a hard time with getting the updates working. I tried a few things from google search to get it resolved, but no luck. I also registered a hedhat account and could register with 

%   sudo subscription-manager register  --username jejurikar  --password  my_passwd

However I am getting an error stating that no repos are present (output below). In the process of trying to resolve, I happened to delete (as indicated in one of the gogle search posts) the following two files, which seems to be the cause.:

% sudo rm -rf /etc/yum.repos.d/redhat.repo
% sudo rm -rf /etc/yum.repos.d/rhel-dvd.repo

I think this is one of the cause for the issue. How do I get these files back (can someone send me the files and would that resolve). Not sure how to add repositories etc. I think without these repo file I cannot "attach" to get updates. Any guidance would be helpful. Is there anything specific to Intel here or can anyone on the RHEL community resolve this as well?  Please let me know if I can add any more details about the board/OS etc.

Your help is greatly appreciated. Thanks in Advance

-Ravindra Jejurikar

PS :Please let me know if this is there is any other place to post this or get hlep on the same.

[developer@localhost Documents]$ yum check-update
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
              : manager
There are no enabled repos.
 Run "yum repolist all" to see the repos you have.
 To enable Red Hat Subscription Management repositories:
     subscription-manager repos --enable <repo>
 To enable custom repositories:
     yum-config-manager --enable <repo>
[developer@localhost Documents]$ yum repolist all
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
              : manager
repolist: 0

 

[developer@localhost Documents]$ sudo subscription-manager repos --list
[sudo] password for developer:
This system has no repositories available through subscriptions.

0 Kudos
0 Replies