Intel® Software Guard Extensions (Intel® SGX)
Use hardware-based isolation and memory encryption to provide more code protection in your solutions.

Re: In case somebody comes across

AAron1011
Beginner
220 Views

Hello,

I am having a similar issue with SGX. I tried to use the cyberlink advisor but I cannot click on the "not available" result and there is no info icon to the right, so it will not install SGX.

I am running:

Intel Core I5 9400f

ASUS Prime B365M-A

Geforce GT 1030

The Bios in the ASUS board is also set to software controlled. There is no enable choice... Can anyone help further?

0 Kudos
1 Solution
JesusG_Intel
Moderator
203 Views

Hello AAron1011,


Your issue may be due to your OS being installed in Legacy Mode instead of UEFI mode. Enabling SGX via “Software Controlled” can only work if the OS is booted in EFI mode. We have no way to do the enabling in Legacy Mode, unfortunately.


You can find out which mode your OS is booted in by entering the following command in Power Shell as Administrator:


Get-SecureBootUefi -Name SetupMode


If the command comes back with an error then your OS is booted in Legacy Mode and you will have to do some work to enable SGX, as explained below...


There’s usually a switch in the BIOS to go between EFI and Legacy modes. You can’t simply change and then reboot… the OS has to be installed in that mode. If you simply switch it and reboot, it won’t boot.

 

There are only two options:


1) Switch to EFI mode in BIOS and re-install Windows in that mode.


OR


2) Switch to EFI mode in BIOS, boot a live EFI aware Linux distribution (most are these days – Linux Mint works), and then run a utility to enable SGX in that environment. We don’t have an “official” tool for Linux to do this. Read this support thread for full instructions: https://github.com/intel/linux-sgx/issues/354


Regards,

Jesus G.

Intel Customer Support



View solution in original post

2 Replies
JesusG_Intel
Moderator
204 Views

Hello AAron1011,


Your issue may be due to your OS being installed in Legacy Mode instead of UEFI mode. Enabling SGX via “Software Controlled” can only work if the OS is booted in EFI mode. We have no way to do the enabling in Legacy Mode, unfortunately.


You can find out which mode your OS is booted in by entering the following command in Power Shell as Administrator:


Get-SecureBootUefi -Name SetupMode


If the command comes back with an error then your OS is booted in Legacy Mode and you will have to do some work to enable SGX, as explained below...


There’s usually a switch in the BIOS to go between EFI and Legacy modes. You can’t simply change and then reboot… the OS has to be installed in that mode. If you simply switch it and reboot, it won’t boot.

 

There are only two options:


1) Switch to EFI mode in BIOS and re-install Windows in that mode.


OR


2) Switch to EFI mode in BIOS, boot a live EFI aware Linux distribution (most are these days – Linux Mint works), and then run a utility to enable SGX in that environment. We don’t have an “official” tool for Linux to do this. Read this support thread for full instructions: https://github.com/intel/linux-sgx/issues/354


Regards,

Jesus G.

Intel Customer Support



View solution in original post

JesusG_Intel
Moderator
179 Views

This thread has been marked as answered and Intel will no longer monitor this thread. If you want a response from Intel in a follow-up question, please open a new thread.


Reply