Intel® Software Guard Extensions (Intel® SGX)
Use hardware-based isolation and memory encryption to provide more code protection in your solutions.

SGX Eclipse plugin

Sam5
New Contributor I
377 Views

Hi

The eclipse plugin provided with SGX SDK for Linux* OS, only installs SGX user guide and there are no SGX tools available with plugin. How do I get that?

Thank You

0 Kudos
1 Solution
Surenthar_S_Intel
377 Views

Hi Sam,

The eclipse plugin build from commandline requires the following variables to be set

$ECLIPSE_HOME - Path to eclipse home. In order to build the plugin eclipse needs to be installed.
$RELEASE_ID - The release id for the plugin.

The plugin has been tested with the following Eclipse ADT version

Build: v22.3.0-887826

The following plugins are pre-requisites to be installed in Eclipse before trying to build the plugin.

1. Eclipse IDE for C/C++ Developers  4.5.1.20150917-1200 (tested_version)
2. Eclipse PDE Plug-in Developer Resources   3.11.1.v20150904-0345 (tested_version)

If the sgx eclipse plugin is already installed to eclipse and to build and install a newer version, uninstall the old version and start eclipse with the -clean option.
Then try to build the new version of the plugin and install it in eclipse.

http://wiki.eclipse.org/FAQ_How_do_I_remove_a_plug-in%3F

Once the build script is run, the folder build_directory/updatesite/sgx-eclipse-plugin contains the update site. This is the path that needs to be provided to the eclipse while doing installation.

Thanks and Regards,
Surenthar Selvaraj

View solution in original post

4 Replies
Surenthar_S_Intel
378 Views

Hi Sam,

The eclipse plugin build from commandline requires the following variables to be set

$ECLIPSE_HOME - Path to eclipse home. In order to build the plugin eclipse needs to be installed.
$RELEASE_ID - The release id for the plugin.

The plugin has been tested with the following Eclipse ADT version

Build: v22.3.0-887826

The following plugins are pre-requisites to be installed in Eclipse before trying to build the plugin.

1. Eclipse IDE for C/C++ Developers  4.5.1.20150917-1200 (tested_version)
2. Eclipse PDE Plug-in Developer Resources   3.11.1.v20150904-0345 (tested_version)

If the sgx eclipse plugin is already installed to eclipse and to build and install a newer version, uninstall the old version and start eclipse with the -clean option.
Then try to build the new version of the plugin and install it in eclipse.

http://wiki.eclipse.org/FAQ_How_do_I_remove_a_plug-in%3F

Once the build script is run, the folder build_directory/updatesite/sgx-eclipse-plugin contains the update site. This is the path that needs to be provided to the eclipse while doing installation.

Thanks and Regards,
Surenthar Selvaraj

Sam5
New Contributor I
377 Views

Thanks for your detailed information

Savvas_S_
Beginner
377 Views

What should $RELEASE_ID be set to?

Thanks!

Surenthar_S_Intel
377 Views

Hi,

$RELEASE_ID - The release id for the plugin. The release id should be changed for each source codes updates.

-Surenthar

Reply