Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
99 Views

how can i do about the Problem with the local SSL certificate?Could not query IAS

Jump to solution

I wan to run the offical remote attestation example(sgx-ra-example),but the server output is an error:

---- IAS sigrl HTTP Request ------------------------------------------------
HTTP GET https://test-as.sgx.trustedservices.intel.com/attestation/sgx/v3/sigrl/000013dc
----------------------------------------------------------------------------
* Could not resolve proxy: proxy-us.intel.com
* Closing connection 0
Could not query IAS
could not retrieve the sigrl
error processing msg1
Waiting for a client to connect...

 

another ra example output:

1546485734 INFO  : Received extended EPID group ID: 0
1546485734 INFO  : Serialization successful
1546485734 INFO  : Send to client
1546485734 INFO  : MSG1 received
1546485734 INFO  : Retrieving SigRL from IAS
1546485736 INFO  : curl_easy_perform() failed: Problem with the local SSL certificate

1546485736 INFO  :     Response status is: 0
1546485736 INFO  :     Content-Length: 0
1546485736 INFO  : Error, processing MSG1 failed
1546485736 INFO  : Close connection
1546485736 INFO  : Remote attestation done
 

I follow the offical course to get the local SSL certificate:
https://software.intel.com/en-us/articles/how-to-create-self-signed-certificates-for-use-with-intel-...

my local SSL certificate  has been validated:
https://software.intel.com/en-us/articles/certificate-requirements-for-intel-attestation-services

I hope someone can give me some suggestions.

0 Kudos

Accepted Solutions
Highlighted
New Contributor I
99 Views

Configurations of the settings file to disable IAS proxy as the following:
//IAS_PROXY_URL=http://proxy-us.intel.com:911 //annotate this line to disable IAS proxy

and,


IAS_DISABLE_PROXY=1 //Set to non-zero to disable the use of a proxy server.

 

you should annotate the proxy, and other options was correct, this example will run well!

View solution in original post

0 Kudos
3 Replies
Highlighted
New Contributor I
100 Views

Configurations of the settings file to disable IAS proxy as the following:
//IAS_PROXY_URL=http://proxy-us.intel.com:911 //annotate this line to disable IAS proxy

and,


IAS_DISABLE_PROXY=1 //Set to non-zero to disable the use of a proxy server.

 

you should annotate the proxy, and other options was correct, this example will run well!

View solution in original post

0 Kudos
Highlighted
New Contributor I
99 Views

bin, ch wrote:

Configurations of the settings file to disable IAS proxy as the following:
//IAS_PROXY_URL=http://proxy-us.intel.com:911 //annotate this line to disable IAS proxy

and,

IAS_DISABLE_PROXY=1 //Set to non-zero to disable the use of a proxy server.

 

you should annotate the proxy, and other options was correct, this example will run well!

0 Kudos
Highlighted
Beginner
99 Views

Hi bin, ch

 

I am running into the same problem as you and I have also disabled the line  IAS_PROXY_URL="http://proxy-us.intel.com:911"  by using :: 

and SET IAS_DISABLE_PROXY=1

I still got the same message,

Have you probably changed this line SET RA_IAS_CLIENT_CERT_FILE="certificate.pem"

to the name of your self signed certificate?

 

Cheers,

Enio

0 Kudos