Intel® oneAPI Data Parallel C++
Support for Intel® oneAPI DPC++ Compiler, Intel® oneAPI DPC++ Library, Intel® DPC++ Compatibility Tool, and GDB*

How to disable symbol loading?

student4
Beginner
530 Views

Hi,

I have .dll DPC++ project which is invoked in .exe DPC++ project.When I compile the program I see this window. The loading of symbols takes a very very long time. Is there a way I can disable it.
I am using Microsoft Visual Studio 2019 for project development.

 

I appreciate your help.

Thank you.

student4_0-1647251286103.png

 

0 Kudos
3 Replies
DitiD_Intel
Moderator
459 Views

Hi,


Thank you for posting in Intel Communities.


Could you please provide us with a sample reproducer along with the version of dpcpp compiler that you are using, so that we can investigate the issue from our end?


Please follow the steps mentioned below, they might help in resolving your issue.


Go to Tools -> Options -> Debugging -> Symbols -> Automatic symbol loading preference -> Specify excluded modules and enter the list of the dlls which take too long to load.


Go to Tools -> Options -> Debugging -> General and enable the option 'Enable Just My code'.  


Thanks and Regards,

Ditipriya.



DitiD_Intel
Moderator
434 Views

Hi,


We've not heard back from you. Can you please provide an update?


Thanks and Regards,

Ditipriya.


DitiD_Intel
Moderator
406 Views

Hi,


We have not heard back from you. This thread will no longer be monitored by Intel. If you need further assistance, please post a new question.


Thanks & Regards,

Ditipriya.



Reply