Intel® oneAPI HPC Toolkit
Get help with building, analyzing, optimizing, and scaling high-performance computing (HPC) applications.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
1829 Discussions

Can not execute fortran parallel code with coarray

Jiang__Wei
Beginner
385 Views

The same code works well in intel compiler 2019 and 2020

Win 10+ VS2019+OneAPI

I have followed the instruction at https://software.intel.com/content/www/us/en/develop/documentation/mpi-developer-guide-windows/top/c...

Console2.exe - System Error
The code execution cannot proceed because impi.dII was not found. Reinstalling the program may fix this problem.

Note there is an error in the automatic system path, the MPI path is now
$I_MPI_ONEAPI_ROOT not $I_MPI_ROOT

and there is no "\intel64"

Please fix this, thanks!

A small example can be found in the attachment.

0 Kudos
6 Replies
AbhishekD_Intel
Moderator
364 Views

Hi,

 

Thanks for reaching out to us.

I tried the project that you have shared and didn't find any errors while executing that project it's compiling and executing without any errors, I tried it with VS2019 and oneAPI latest toolkit.

 

You have pointed out the correct thing for the system path. There are some changes in the directory structure of PSXE and oneAPI, so if you are trying to use the older projects you have to make some changes in your project configurations.

 

Do let us know if you are having any more issues.

 

 

Warm Regards,

Abhishek

 

 

 

Jiang__Wei
Beginner
346 Views

Hi Thanks for the reply!

 

Have you tried to debug or execute the code I have uploaded?
Indeed, I can compile and link the file and the exe file is generated properly. But I can not debug or execute it.

There is always an error like

Console2, exe - System Error
The code execution cannot proceed because libifcoremdd.dII
was not found. Reinstalling the program may fix this problem

I have tried to reinstall both vs2019 and oneapi but the problem still exists. The sereial code just works fine.  

I noticed that similar error have been reported as well at
https://community.intel.com/t5/Intel-oneAPI-HPC-Toolkit/I-MPI-ROOT-issue-in-VS-after-installing-onea...

AbhishekD_Intel
Moderator
314 Views

Hi,

 

So sorry for the delay.

Yes, I have also executed the same sample project provided by you, and it's working without any linking error.

It got successfully compiled and successfully executed on my side. I used the same configuration as sent by you.

 

The linking error is at libifcoremdd.dll so please also check if the same dll is present at the below location.

C:\Program Files (x86)\Intel\oneAPI\compiler\latest\windows\redist\ia32_win\compiler

 

I can see in my debug logs it's picking the same dll for the same configurations. So I the issue is with your VS environment. Please verify it and let us know your results.

 

I have attached my debug logs which I got after successfully executing your project in debug mode, and check at what point your project is throwing errors.

 

Hope this will help you to resolve your issue. Do let us know if you still have any issues related to this thread.

 

Warm Regards,

Abhishek

 

AbhishekD_Intel
Moderator
304 Views

Hi,


Please give us an update on the provided details. Also do let us know if the issue is resolved.


Warm Regards,

Abhishek


AbhishekD_Intel
Moderator
299 Views

Hi,


We haven't heard back from you for a long time. So we are assuming that the provided details had helped you in solving your issue. We will no longer monitor this thread.

Please post a new thread if have any other issues.


Warm Regards,

Abhishek


Jiang__Wei
Beginner
214 Views

https://software.intel.com/content/www/us/en/develop/articles/oneapi-standalone-components.html

Hi, we have fixed it by ourselves for some time but did not feedback. The problem is solved by installing above libs.

Thanks!

Reply