Community
cancel
Showing results for 
Search instead for 
Did you mean: 
John_H_19
Beginner
307 Views

Irqbalance update affinity_hint and banned cpus conflict

I have a cluster with Ominpath nodes and CentOS 7.2.

On Sunday I upgraded the irqbalance package to irqbalance-1.0.7-6

The system is now repeatedly logging /usr/sbin/irqbalance: irq NN affinity_hint and banned cpus conflict

In /etc/sysconfig/irqbalance I have set IRQBALANCE_ARGS=--hintpolicy=exact

Looking at Redhat bugzilla, this seems to be a know issue. Has anyone seen it and is there a known workaround?

0 Kudos
3 Replies
Dmitry_S_Intel
Employee
307 Views

Hi,

It looks like OS related issue.

For ignoring hintpolicy can you test adding the

OPTIONS="--hintpolicy=ignore"

to /etc/default/irqbalance file ?

--

Dmitry

John_H_19
Beginner
307 Views

Dimitri, this is indeed an OS issue.

I have a bug opened on CentOS for it, and someone else reports the same thing on am Omnipath equipped cluster.

setting irqbalance=ignore   then there are no messages logged when irqbalance is started

 

Dmitry_S_Intel
Employee
307 Views

Ok, so root cause is identified.

In Intel® Omni-Path Performance Tuning User Guide we have the recommendations:

Setting --hintpolicy to exact is needed to work with the Receive and SDMA interrupt algorithms in the HFI1 driver.

So probably you need to wait for OS fix.

--

Dmitry

Reply