Intel® oneAPI Math Kernel Library
Ask questions and share information with other developers who use Intel® Math Kernel Library.
7031 Discussions

Error installing mkl-devel with pip on MacOS CI

VNMabus
Beginner
711 Views
I am executing pip install mkl-devel in my CI in Github actions. Now, in MacOS it tries to install an older version of mkl-devel (it only considers 2018.0.0 and 2018.0.3 as candidates), and it is not able to resolve them. However, on the 24th of April the CI on MacOS was just fine, and it installed mkl-devel in version 2023.2.1. The next CI two days later failed. I guess that version 2023.2.2 released on 25th April may have something to do with it. Do you know what may be the problem?
Labels (1)
0 Kudos
6 Replies
SofeaAzrin_A_Intel
650 Views

Thank you for your question.


You may need to try the latest version 2024 or it maybe relates to any libraries linking issue. Please refer to this link https://www.intel.com/content/www/us/en/developer/tools/oneapi/onemkl-link-line-advisor.html#gs.8lg1xb . Also you may refer to this article on mkl-devel https://www.intel.com/content/www/us/en/docs/onemkl/get-started-guide/2024-0/overview.html



0 Kudos
VNMabus
Beginner
637 Views

Thank you for answering. As I mentioned in my question, I cannot install a newer version as pip only considers 2018.0.0 and 2018.0.3 as candidates. The version 2023.2.1, which I installed before without problems, is now not considered compatible by pip.

0 Kudos
SofeaAzrin_A_Intel
580 Views

Hi,


I need more details on the error you get when trying to install 2023.2.1 in your MacOS. If you have the screenshot, you can attach it together here.


0 Kudos
VNMabus
Beginner
556 Views

I have the problem in Github CI: https://github.com/GAA-UAM/scikit-fda/actions/runs/9050779738/job/24866531914

 

I attach a screenshoot too, in case the test results are removed.

 

0 Kudos
Vipin_Singh1
Moderator
421 Views

Hi Carlos, Intel® has decided that Intel Libraries, Analysis, and AI Tools Versions: 2024.0.0 and earlier are not supported anymore. We urge users to upgrade to the latest version of Intel® developer tools. The unsupported versions do not include the latest functional and security updates. These versions are targeted to be removed after a period. We understand that this might be challenging, but it's important to note that the users with active priority support can only access older product versions.

 

For more information refer to the link: https://www.intel.com/content/www/us/en/developer/articles/release-notes/oneapi-supported-product-versions.htm, and scroll down to the Unsupported Product Version.

 

Intel® oneAPI users with active Intel Priority Support can access older versions via a secure portal you gain access to as part of your support subscription. 

 

FAQ's Priority Support Link: https://www.intel.com/content/www/us/en/developer/get-help/faq-priority-support.html


0 Kudos
Vipin_Singh1
Moderator
375 Views

Hi Carlos, unfortunately, we were unable to hear back from you. 


If you have any further queries, please post a new question, as this thread will no longer be monitored by Intel®. 


0 Kudos
Reply