Community
cancel
Showing results for 
Search instead for 
Did you mean: 
STOFFEL__Mathieu
Beginner
100 Views

[HPCG] "QuickPath" option always selected

Hello everyone,

 

A brief summary of the issue:

  • The Intel MKL and Intel MPI libraries are installed on the cluster I am using (its compute nodes embed 2 sockets (E5-2620 v4));
  • The AVX2 pre-built binary of HPCG delivered with the Intel MKL (xhpcg_avx2) executes successfully, both on a single node and on multiple nodes;
  • I tried to set a target execution time by using either the --rt=180 command line option, or the hpcg.dat configuration file (which is in the same directory as the binary), and by using both at the same time. However, the setting of the target execution time simply seems to be ignored, since the QuickPath option is always used (confirmed by the YAML output file);
  • However, setting the size of the local 3D compute grid works perfectly, thanks to both the command-line options and the configuration file.

 

I could not find any information related to such an issue (however, there is a closed issue in the GitHub repository of HPCG concerning the fact that if the --rt command-line option was not specified, the QuickPath option was enforced).

 

Any idea/workaround? If you need some more information, or if you want me to test something, just ask.

 

Thank you in advance for your help,

--Mathieu.

0 Kudos
0 Replies
Reply