Community
cancel
Showing results for 
Search instead for 
Did you mean: 
thebuttonfreak
Beginner
51 Views

Linking intel MKL to xcode 3.2.4

Hey,
I'm running Fortran Intel 64 Compiler XE for applications running on Intel 64, Version 12.0.4.184 Build 20110503 with xcode 3.2.4 and xcode 4.0.2. I am trying a to link MKL to both versions of xcode. I am using these articles as a guide
I have this working in the xcode debugger console but when I try to run it through my mac terminal it gives the error
dyld: Library not loaded: libmkl_intel_lp64.dylib Referenced from: /Users/charlescherqui/Documents/MKL_dgemm_f/build/Debug/MKL_dgemm_f
Reason: image not found
Trace/BPT trap
logout
[Process completed]
I am using the example code from the forst link I posted. Can antone tell me why it would work in the xcode debugger window but not my mac window? I really want to use this in xcode 3.2.4 since it has the syntax coloring and xcode 4 does not (is that fixed btw?), I just got it working in xcode 4 first since it was a bit easier to do so, I then got it working in xcode 3.2.4, but in both cases only in the debugger window. Thanks.
0 Kudos
3 Replies
barragan_villanueva_
Valued Contributor I
51 Views

Hi,

Maybe you need to use mklvars.* to create correct envirinmet for MKL in your terminal before.
Please check that libmkl_intel_lp64.dylibcan be found by your DYLD_LIBRARY_PATH settings
Ying_H_Intel
Employee
51 Views

Hi Thebuttonfreak,

The error message dyld: Library not loaded: libmkl_intel_lp64.dylib means the system can't find the library.

So whatever in Xcode environment (either4.0 or 3.2.4)or in terminal environment, to define DYLD_LIBRARY_PATH environment variable is required.

You candefinethe variable eitherby mklvars.* or define the DYLD_LIBRARY_PATH manually.

I upload a terminal environment screencopy for your reference. ( i'm use putty, but it should be same if you start a terminal windows from MaC OS desktop.

Best Regards,
Ying
thebuttonfreak
Beginner
51 Views

Thanks, I updated my path and it worked like a charm.
Reply