Intel® oneAPI Math Kernel Library
Ask questions and share information with other developers who use Intel® Math Kernel Library.
6539 Discussions

Problems in running MKL fortran example

Ding_L_
Beginner
143 Views

Dear all,

After the example fortran code vdrnggaussian.f successfully compiled (in visual studio 2010+Intel Parallel Studio XE 2013), the resulting executable file returns the following error message:

MKL ERROR: Parameter 1 was incorrect on entry to vdRngGaussian.
Error: bad arguments (code    -3).

What should I do to get the right results? Many thanks for your help.

 

 

0 Kudos
1 Solution
mecej4
Black Belt
143 Views

I think that you should not have used mkl_intel_ilp64_dll.lib unless you have other settings that make the integer arguments to MKL routines to be 8-byte integers. Use mkl_intel_lp64_dll.lib instead.

View solution in original post

5 Replies
mecej4
Black Belt
143 Views

Please state the specific version numbers of the compiler, e.g., Version 14.0.3.202 Build 20140422, the MKL version used, and the options used to build the application.

I built the version of the example included in Composer 2013 SP1, and it ran fine with no errors.

Ding_L_
Beginner
143 Views

Dear mecej4,

Many thanks for your reply.

The version I am using for the compiler is Intel(R) Visual Fortran Compiler XE 13.1 for Windows (13.1.0.149), and the MKL is Intel(R) Math Kernel Library 11.0 Update 2 for Windows (11.0.2.149).

The project properties are set as follows:

Fortran—>general—>Additional Include Directories:

C:\Program Files (x86)\Intel\Composer XE 2013\mkl\include

Linker—>general—>Additional Library Directories:

C:\Program Files (x86)\Intel\Composer XE 2013\mkl\lib\intel64

Linker—>Input—> Additional Dependencies: mkl_intel_ilp64_dll.lib mkl_core_dll.lib mkl_sequential_dll.lib

Looking forward to any further help. Thanks.

mecej4
Black Belt
144 Views

I think that you should not have used mkl_intel_ilp64_dll.lib unless you have other settings that make the integer arguments to MKL routines to be 8-byte integers. Use mkl_intel_lp64_dll.lib instead.

Gennady_F_Intel
Moderator
143 Views

see more details in mkl user's guide -- Using the ILP64 Interface vs. LP64 Interface

Ding_L_
Beginner
143 Views

Hi both,

Many thanks for your help. It works now. Cheers.

Reply