Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
11 Views

Running in Release Configuration

I installed the MKL library for the evaluation period less than a month ago. I am able to run my code in the debug mode using Visual Studio. However the release version has errors at run time stating the, "Application has failed to start because mkl_squential.dll was not found. Re-installing the application may fix this problem." I have tried re-installing, but the same error occurs. Did I install MKL incorrectly?

Thank you.

0 Kudos
7 Replies
Highlighted
Valued Contributor I
11 Views

Hi,

probably your release config is incorrect (paths misconfigured or not set) so system can't find the dll (at runtime), I mean system can't find the dll in places where they are supposed to be. How do you run your app (inside VS?, command line?).

In VS you need to set up libraries for the Release config the same way as you did for Debug (yes, you need to copy/reset).

A.

0 Kudos
Highlighted
Beginner
11 Views

I set up the libraries in Tools -> Options -> Projects and Solutions -> VC++ Directories (as the MKL manual described). Should that not work for both Debug and Release Config? Also, the application is run inside VS with a form.

0 Kudos
Highlighted
Valued Contributor I
11 Views

What about the last step in the User's Guide, namely,

6. Select Project > Properties > Configuration Properties > Linker > Input > Additional Dependencies

This is the place where (per cofiguration, I mean for Debug and Release) you need to set the libraries.

Is it also correct?

A.

0 Kudos
Highlighted
Beginner
11 Views

mkl_sequential_dll.lib is in the Additional Dependencies for both Debug and Release.

I can't find any differences between debug and release. Does the Evaluation version of MKL normally work in Release config?

0 Kudos
Highlighted
Black Belt
11 Views

That's right. In effect, there are only Release versions of MKL libraries. The Evaluation is identical to the full version.
0 Kudos
Highlighted
Employee
11 Views

Hello,

The PATH environment variable should contain full path to MKL 'ia32\bin' directory. For example if you have MKL 10.2.3.029 installed into its default directory, you should set the PATH variable before your application launch like this:

set PATH=C:\Program Files\Intel\MKL\10.2.3.029\ia32\bin;%PATH%

It also can be performed by launching 'tools\environment\mklvars32.bat' script.

For setting program execution environment in Visual Studio IDE select Project > Properties > Debugging > Environment and define PATH variable as described above.

Thanks,

Art

0 Kudos
Highlighted
Beginner
11 Views

Setting the path fixed my problem. Thank you, Art.
0 Kudos