Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ic-admin
Beginner
28 Views

SIGSEGV calling blacs_gridinit

Hello,
Using Intel 11.1-f064-c064 compiler and openmpi 1.4.1
Getting the following segmemtation fault

mpiexec -np 8 ./test
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source
libmpi.so.0 00002AE0891FC830 PMPI_Comm_size 46 pcomm_size.c
libmkl_blacs_inte 00002AE0889D9383 Unknown Unknown Unknown
-snip-

Routine listed below- along with output from run

Any suggestions woudl be greatly appreciated.

program test
implicit none
include 'mpif.h'
character(1) :: order
integer :: comm, error, myproc, nprocs, nc, nr

call MPI_INIT(error)
comm = MPI_COMM_WORLD
call MPI_COMM_RANK(comm,myproc,error)
call MPI_COMM_SIZE(comm,nprocs,error)

nr = int(sqrt(real(nprocs)))
nc = nprocs/nr

order = 'R'

if (myproc == 0) then
write(37,'("comm = ",i0)') comm
write(37,'(/,"number of rows = ",i0)') nr
write(37,'("number of columns = ",i0)') nc
write(37,'(/,"order = ",a1)') order
end if
if (myproc == 0) write(37,'(/,"before call to blacs_gridinit")')
call blacs_gridinit(comm,order,nr,nc)
if (myproc == 0) write(37,'(/,"after call to blacs_gridinit")')

call MPI_FINALIZE(error)
end program


cat fort.37
comm = 0

number of rows = 2
number of columns = 4

order = R

before call to blacs_gridinit

0 Kudos
2 Replies
28 Views

From the first look, the problem is inthe version of OpenMPI.MKL 10.2.x supports only OpenMPI 1.2.x.
Is this happening with OpenMPI 1.2.x?

--Vipin

ic-admin
Beginner
28 Views

Issue resolved by using mkl_blacs_openmpi instead of mkl_blacs_intelmpi. We are running openmpi-1.4.1 with 11.1.064 Intel compiler.